5 Replies Latest reply on May 24, 2010 9:48 PM by Freeman(Yue) Fang

    bundle couldn't resolve: package uses conflict

    Chongkai Jiang Newbie

      Hi folks,

       

      I'm using FUSE ESB 4.2, trying to deploy a bundle that contains a jax-ws endpoint. When I try to start the bundle, I get this error message,

       

      The bundle could not be resolved. Reason: Package uses conflict: Require-Bundle: org.apache.cxf.bundle; bundle-version="2.2.6.fuse-01-00"

       

      The following is my bundle headers:

       

      Manifest-Version = 1.0

      Built-By = cjiang

      Created-By = Apache Maven Bundle Plugin

      Import-Package = javax.jws;version="2.0",javax.jws.soap;version="2.0",javax.xml.bind,javax.xml.bind.annotation,javax.xml.namespace,javax.xml.ws,org.apache.commons.codec.binary;version="1.4",org.apache.log4j,org.apache.log4j.xml,org.apache.xmlbeans,org.osgi.framework;version="1.3",org.springframework.beans.factory.config;version="2.5"

      Bnd-LastModified = 1274714946465

      Export-Package =

      Bundle-Name = xx

      Build-Jdk = 1.5.0_17

      Private-Package = wsdl,wsdl.xsd

      Bundle-ManifestVersion = 2

      Tool = Bnd-0.0.255

      Require-Bundle = org.apache.cxf.bundle; bundle-version="2.2.6.fuse-01-00"

       

      What could be the cause for this error? How can I debug?

       

      Thanks,