3 Replies Latest reply on Aug 20, 2010 5:23 PM by Robert Srna

    FUSE ESB 4.1 in Solaris

    George Petrakis Newbie

      Hello again,

       

      I have installed fuse 4.1 on solaris environment and I am facing the following problem:

       

      I need to run esb in background and be able to access smx@root. Please please if anyone has any idea...

       

      I have tried: /bin/nohup servicemix server & 

      but when I try to login to smx using ssh smx@ -p 8101

      I get connection refused.

       

      Please for you help.

       

      Thanks in advance

        • 1. Re: FUSE ESB 4.1 in Solaris
          Gert Vanthienen Novice

          L.S.,

           

          We fixed this in FUSE ESB 4.2.0-fuse by adding a bin/start script that does the necessary bits to run the container in the background.  If that's possible, I would recommend you to switch to that version as it also comes with a lot of other fixes/improvements/...

           

          For the 4.1.0.x-fuse version, the easiest way to accomplish the same result is by using the wrapper feature.  The first time, you start ServiceMix interactively and you run these two commands in the ServiceMix console:

          smx@root:></![CDATA[> features/install wrapper
          smx@root:/> wrapper/install 
          

           

          This will create a bin/servicemix-service script, that allows you to start servicemix as a service, e.g. {{bin/servicemix-service start}} to start the service.  When the container is started this way, I can establish the ssh connection afterwards on my OpenSolaris VM.

           

          Regards,

           

          Gert Vanthienen

          • 2. Re: FUSE ESB 4.1 in Solaris
            George Petrakis Newbie

            Thank you for your answer, I will try it.

            • 3. Re: FUSE ESB 4.1 in Solaris
              Robert Srna Newbie

              I have similar problem. Following your suggestion (wrapper install) I found no servicemix-service script. Where did I do a mistake?