3 Replies Latest reply on Jul 13, 2010 8:28 PM by Willem Jiang

    Problems calling webservices from FUSE

    Morten Engel Newbie

      I've made a webservice using wsdl2java through Eclipse, but I'm having problems starting it in Fuse.

       

      There's no compile or maven install errors when I develop it on my own environment, I can debug through it and see it call on local env. as well, but after it's installed in FUSE and I attempt starting it, I get the message:

       

      "The bundle could not be resolved. Reason: Missing Constraint: Import-Package: javax.xml.rpc; version="0.0.0".

       

      Originally, jaxrpc-api was a normal external dependency on the project, but the problem persists after changing it to a maven dependency.

       

      I've also tried moving this package - as well as others, to the deploy folder, and installing and starting these, no problems doing this. But I still get the error.

       

      How should I include this package in Fuse/My project?

        • 1. Re: Problems calling webservices from FUSE
          Claus Ibsen Master

          Could you report the FUSE version and JDK version you are using?

           

          And have you installed any features / osgi bundles yourself?

          Which webservice stack are you using? For example CXF?

           

          And the webservice you have created, is a webservice you want hosted in FUSE ESB? So other clients can invoke your web service? i.e. you are the server.

          • 2. Re: Problems calling webservices from FUSE
            Morten Engel Newbie

            Hi Claus,

             

            Thank you for your reply, however I believe to have stumbled upon a solution myself meanwhile.

             

            The answer to my problem, was to "wrap" the needed jar into a bar, and place it in the deploy folder.

             

            However, if that sounds like a terrible solution, I'd love to hear alternatives.

             

            As for fuse version, I guess this should do it; apache-servicemix-4.2.0-fuse-01-00

            There are several osgi bundles installed as well as features enabled - anything in specific needed, or known to create any problems?

             

            The webservice is an external webservice, which I need to call from FUSE, it's implemented as a .NET wsdl.

            • 3. Re: Problems calling webservices from FUSE
              Willem Jiang Master

              If you are using CXF , you don't need any jax-rpc jars and CXF provides the implementation of JAX-WS which is not compatible with JAX-RPC.

               

              Fuse ESB provides out of box support of Fuse SF (based on Apache CXF), you just need to install cxf feature.

               

              So please check your bundle and remove  that part of dependency.

               

              Willem