7 Replies Latest reply on Sep 24, 2010 6:02 AM by Jaymin Shah

    TSS.war (based on http://appfuse.org/) with Fuse v4.3

    Jaymin Shah Newbie

      Hi,

       

      I have been trying to install war file on Fuse using v4.3 (apache-servicemix-4.3.0-fuse-00-00).

       

      I have followed following steps:

       

      1)     Install apache-servicemix-4.3.0-fuse-00-00 and start

      2)     features:install war

      3)     osgi:install war:file:D:/FUSE_ServiceMIX/helloworld.war?Webapp-Context=helloworld&Bundle-Name=helloworld&Bundle-Version=1.0.0

      4)     http://localhost:8181/helloworld/hi.jsp

       

      I am able to access above link properly since it does not have major implementation like JSTL and other Java/Tags. After successful installation, I have tried to install TSS.war (based on http://appfuse.org/). It has failed to launch index.jsp page (Attached error file). Note that this application is working well on tomcat and I have ensured that that there are tomcat specific usage.

       

      Can some please let me know where can I specify default XML provider in Fuse so that attached error can be removed. Also, note that I have NOT changed lib and jar and kept it as it is under WEB-INF folder for this case. Please let me know if I need to deploy it separately.

       

      Thanks,

      Jay

        • 1. Re: TSS.war (based on http://appfuse.org/) with Fuse v4.3
          Claus Ibsen Master

          Can you try with FUSE ESB 4.3-01-00 version.

          • 2. Re: TSS.war (based on http://appfuse.org/) with Fuse v4.3
            Jaymin Shah Newbie

            Thanks for your swift reply.

             

            I have tried to search download location for FUSE ESB 4.3-01-00 version but could not find one on fusesource.com.

             

            The current download shows Apache ServiceMix v4.3.0-fuse-00-00 (Windows) only.

             

            I would appreciate your sharing download location for for FUSE ESB 4.3-01-00 version.

             

            regards,

            Jaymin

            • 4. Re: TSS.war (based on http://appfuse.org/) with Fuse v4.3
              Gert Vanthienen Novice

              L.S.,

               

              If the 4.3.0-fuse-01-00 version is showing the same problem, could you provide us with a small war file that shows the problem (just a single page or something) or could you let us know which of the appfuse archetypes we can use to reproduce the issue?

               

              Thanks,

               

              Gert

              • 5. Re: TSS.war (based on http://appfuse.org/) with Fuse v4.3
                Jaymin Shah Newbie

                Gert,

                 

                While I am trying to download and try with 4.3.0-fuse-01-00 version, please find below steps I used.

                 

                1) Install MySQL with admin set to "root" and no password

                 

                2) mvn archetype:generate -B -DarchetypeGroupId=org.appfuse.archetypes -DarchetypeArtifactId=appfuse-basic-struts-archetype -DarchetypeVersion=2.1.0-M2-SNAPSHOT -DgroupId=com.mycompany -DartifactId=myproject -DarchetypeRepository=http://oss.sonatype.org/content/repositories/appfuse

                 

                3) In case MySQL root has password then change it by searching org.hibernate.dialect.MySQL5InnoDBDialect

                 

                4) Run mvn (this will run maven in default install mode)

                 

                5) It will create war file under ?target\myproject-1.0-SNAPSHOT.war?

                 

                6) Deploy this war on tomcat (I had used v6.0.20) to ensure that it is working fine. (Login with user admin password admin). Confirmed that it is working fine.

                 

                7) Now deploy this war on Fuse using following command. (I have ensured that I am working on fresh copy of Fuse (apache-servicemix-4.3.0-fuse-00-00)

                 

                7.a)  Install apache-servicemix-4.3.0-fuse-00-00 and start

                 

                7.b)  features:install war

                 

                7.c)  osgi:install war:file:D:/FUSE_ServiceMIX/myproject-1.0-SNAPSHOT.war?Webapp-Context=myproject&Bundle-Name=myproject&Bundle-Version=1.0.0

                 

                7.d)  Start the OSGI bundle using OSGI:start command, in may case it was ?osgi:start 182?. It has thrown following error. But status shown as therefore tried to access it using http://localhost:8181/myproject and got above error i.e. in initial post.

                 

                karaf@root> osgi:start 182

                2010-09-21 23:58:37.187:WARN::failed encodingFilter: java.lang.NoClassDefFoundError: Could not initialize class org.apac

                he.log4j.LogManager

                2010-09-21 23:58:37.203:WARN::failed encodingFilter: java.lang.NoClassDefFoundError: Could not initialize class org.spri

                ngframework.beans.BeanWrapperImpl

                2010-09-21 23:58:37.234:WARN::failed encodingFilter: java.lang.NoClassDefFoundError: Could not initialize class org.spri

                ngframework.beans.BeanWrapperImpl

                2010-09-21 23:58:37.250:WARN::failed encodingFilter: java.lang.NoClassDefFoundError: Could not initialize class org.spri

                ngframework.beans.BeanWrapperImpl

                2010-09-21 23:58:37.265:WARN::failed encodingFilter: java.lang.NoClassDefFoundError: Could not initialize class org.spri

                ngframework.beans.BeanWrapperImpl

                2010-09-21 23:58:37.281:WARN::failed encodingFilter: java.lang.NoClassDefFoundError: Could not initialize class org.spri

                ngframework.beans.BeanWrapperImpl

                2010-09-21 23:58:37.296:WARN::failed encodingFilter: java.lang.NoClassDefFoundError: Could not initialize class org.spri

                ngframework.beans.BeanWrapperImpl

                2010-09-21 23:58:37.312:WARN::failed encodingFilter: java.lang.NoClassDefFoundError: Could not initialize class org.spri

                ngframework.beans.BeanWrapperImpl

                2010-09-21 23:58:37.328:WARN::failed encodingFilter: java.lang.NoClassDefFoundError: Could not initialize class org.spri

                ngframework.beans.BeanWrapperImpl

                2010-09-21 23:58:37.359:WARN::failed encodingFilter: java.lang.NoClassDefFoundError: Could not initialize class org.spri

                ngframework.beans.BeanWrapperImpl

                2010-09-21 23:58:37.390:WARN::failed encodingFilter: java.lang.NoClassDefFoundError: Could not initialize class org.spri

                ngframework.beans.BeanWrapperImpl

                 

                I hope this would help.

                 

                regards,

                Jaymin

                 

                Edited by: jaymin74 on Sep 22, 2010 2:37 AM

                • 6. Re: TSS.war (based on http://appfuse.org/) with Fuse v4.3
                  Jaymin Shah Newbie

                  Gert,

                   

                  4.3.0-fuse-01-00 version is showing the same problem. I have followed above steps and confirmed that problem is duplicated.

                   

                  I have tried to create sample WAR with spring and JSTL to duplicate the problem but could not duplicate it. It seems that problem is with the appfuse archetype projects or its lib bundling or some configuration.

                   

                  thanks,

                  Jaymin

                  • 7. Re: TSS.war (based on http://appfuse.org/) with Fuse v4.3
                    Jaymin Shah Newbie

                    Freeman, Gert,

                     

                    Any luck on above problem?

                     

                    regards,

                    Jaymin