2 Replies Latest reply on Oct 28, 2010 12:40 PM by Herve BARRAULT

    Deployment not always working with SF 2.2.9

    Herve BARRAULT Newbie

      Hi,

      We are using SF 2.2.9 to create cxf endpoints.  On deployment under fuse ESB 4.3.0-fuse-01-00, we have some issues.

      Randomly, the cxf endpoint is not well deployed under jetty (when calling the defined endpoint we obtains a 404 error). We can't see in log the difference between a correct and an incorrect deployment.

       

      Is there any known issue which can be related to this problem ?

        • 1. Re: Deployment not always working with SF 2.2.9
          Freeman(Yue) Fang Master

          Hi,

           

          Would you please provide more infomation here? Something like your cxf endpoint configuration?

           

          Freeman

          • 2. Re: Deployment not always working with SF 2.2.9
            Herve BARRAULT Newbie

            Hi,

             

            The cxf endpoint is simple :

             

             

             

             

            I have noticed that

                - the addServent method is always called in JettyHTTPHandler when the bundle is started.

                - The removeServant method is always working when stopping the bundle, it can find the JettyHTTPHandler related to the URL.

                - when we have the bug (404 error) , the getHandlers method in org.mortbay.jetty.handler.ContextHandlerCollection#handle does not return all handlers. (for example it returns 3 handlers instead of 4, because addServant has been called 4 times for 4 differents endpoint (also different URL)).

             

            I supposed that something goes wrong when registering

             

            Edited by: tha_hba on Oct 28, 2010 4:27 PM