3 Replies Latest reply on Jan 20, 2011 10:50 AM by Rich Kaltenstein

    Missing org.apache.servicemix.common.osgi; version="0.0.0

    Luc Carpentier Newbie

      Hello,

       

      I'm using the fuse 4.3.0-fuse-02-00 and i'm getting this weird error:

       

      org.osgi.framework.BundleException: The bundle "dms-bc_0.0.1.SNAPSHOT " could not be resolved. Reason: Missing Constraint: Import-Package: org.apache.servicemix.common.osgi; version="0.0.0"

              at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolverError(AbstractBundle.java:1317)[osgi-3.6.0.v20100517.jar:]

              at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolutionFailureException(AbstractBundle.java:1301)[osgi-3.6.0.v20100517.jar:]

       

       

      what feature is this in? Which feature do i need to install.

      The same package works on a 4.3.0-fuse-00-00, so it must be some missing feature.

      I am using the

       

      karaf.framework=equinox

       

      configuration.