1 Reply Latest reply on Jan 11, 2011 3:45 PM by Pavol Noha

    Bundle start problem

    Pavol Noha Newbie



      After i installed camel-example-osgi from apache-camel-2.5.0-fuse-00-00 examples into

      osgi container and try to run this error happen :


      Error executing command: The bundle "org.apache.camel.camel-example-osgi_2.5.0.fuse-00-00 194" could not be resolved.

      Reason: Missing Constraint : Import-Package: org.apache.camel.builder; version="[2.5.0,2.6.0)"


      Any idea how to solve this problem?


      Step to reproduce:


      1.maven install (from eclipse (Build success))

      2.osgi:install -s file:(path to .jar file)

      3.osgi:list (i'm able to see bundle with ID) - 194

      4.osgi:start 194 (error happen)


      Thanks for any response.


      (Camel core feature is installed)