6 Replies Latest reply on Jan 26, 2011 7:40 AM by chris white

    Fuse 5.4.2 Plugin Problem

    chris white Newbie

      Hi all,

       

      Im having trouble getting an authorisation plugin designed for activemq 5.3 running on the latest release of fuse message broker.

       

      I have tracked the problem down after adding extra logging to the following exception on loading the xml file for the plugin

       

       

      INFO |  Line 9 in XML document from class path resource is invalid; nested exception is org.xml.sax.SAXParseException: Attribute "xmlns" must be declared for element type "beans".

       

      and the security.xml file in question looks like so:

       

       

      <?xml version="1.0" encoding="UTF-8"?>

      <!DOCTYPE beans PUBLIC "-//SPRING//DTD BEAN//EN"

          "http://www.springframework.org/dtd/spring-beans.dtd">

       

      <!--

         A sample configuration file for the TTM Security Plugin.

      -->

       

      <beans xmlns="java://org.ttm.security">

       

       

      Does anyone know how to resolve this?

       

      Thanks

       

      Kris