5 Replies Latest reply on Feb 21, 2011 6:52 AM by Pavol Noha

    Logger

    Pavol Noha Newbie

      Hi guys,

       

      have a some problem with logger in servicemix. I'm using some kind of logger which u can see below to know what's happening in my code.

       

      import org.slf4j.Logger;

      import org.slf4j.LoggerFactory;

       

      public final static Logger logger = LoggerFactory.getLogger(ServiceImpl.class);

       

      logger.info("blabla");

       

      The problem is that logger was working excellent and i didn't make any big changes in code but yesterday somethimes i'm able to see what's in logger but somethimes not and i don't know why. The changes related to methods which i'm using are always done so there is no problem in code as well.

       

      Any idea why sometimes logger show me whats happening and somethimes not ?

      For example i run some methods 5 times and 4 of that works and once not ..

       

      I've also tried to set logger in servicemix like log:set info but doesn't help.

        • 1. Re: Logger
          Claus Ibsen Master

          What version of the ESB are you using? And do you hot-deploy bundles and as a result of that the logger may not "work" ?

          • 2. Re: Logger
            Willem Jiang Master

            It much like a Fuse ESB issue instead of Fuse SF issue.

            You should give us more information about your application for investigation.

             

            Willem

            • 3. Re: Logger
              Pavol Noha Newbie

              Hi Willem,

               

              the description of my application (part of that) is in next thread where i'm solving problem with SOAPFaultException. Could you please check ? . Thanks.

               

              4 davsclaus : i'm using apache-servicemix-4.3.1-fuse-00-00 and always use

              this command for deploy:

               

              osgi:install mvn:com.blabla/blabla/0.0.1-SNAPSHOT

               

              Edited by: nohaapav on Feb 20, 2011 1:34 PM

              • 4. Re: Logger
                Freeman(Yue) Fang Master

                Hi,

                 

                Just one note,

                osgi:install mvn:com.blabla/blabla/0.0.1-SNAPSHOT

                just install but not start the bundle,

                using

                osgi:install -s mvn:com.blabla/blabla/0.0.1-SNAPSHOT

                start the bundle.

                 

                Freeman

                • 5. Re: Logger
                  Pavol Noha Newbie

                  Yes i know .. after that i'm using always osgi:start bundlenumber but in most cases it started automatically.

                   

                  But probably it's about queue .. cause me and my college we 're using same oracle queue and when he's not working at all everything seems to be ok .. but after he join same queue he's able to see my log and me not vice versa .. so maybe that's the deal ..

                   

                  I'll try to use another queue for my purpose and i think it will work ok