4 Replies Latest reply on Mar 3, 2011 8:35 PM by Freeman(Yue) Fang

    Cannot Build Source Version of Services Framework

    Wayne Irwin Newbie

      I downloaded the latest version of the source for Services Framework and followed the instructions at http://fusesource.com/docs/framework/2.3/install_guide/IGFSFSrcUnpackBuild.html

       

      I got the following error

      _______________

      BUILD ERROR

      _______________

      Internal error in the plugin manager executing goal 'org.apache.maven.plugins:maven-jar-plugin:2.3.1:jar': Unable to load the mojo 'org.apache.maven.plugins:maven-jar-plugin:2.3.1:jar' in the plugin 'org.apache.maven.plugins:maven-jar-plugin'. A required class is missing: org/codehaus/plexus/components/io/resources/PlexusIoResourceCollection org.codehaus.plexus.components.io.resources.PlexusIoResourceCollection

       

      I resolved this by changing the root pom like this

       

             <groupId>org.codehaus.plexus</groupId>

             <artifactId>plexus-io</artifactId>

             <version>1.0.1</version>

           </dependency>

        </dependencies>

      </plugin>

       

      Has anyone else experienced this?

       

      Thanks

      Wayne

       

      Edited by: wayn23 on Mar 2, 2011 9:14 PM

       

      Edited by: wayn23 on Mar 2, 2011 9:16 PM