2 Replies Latest reply on May 18, 2011 6:38 AM by Massimiliano Andriotto

    ode-jbi-1.3.5 TransactionManager is not recoverable

    Massimiliano Andriotto Newbie

      Hi to all,

      i'm using apache-servicemix-4.3.1-fuse-01-09. I have installed ode features (version 1.3.5) released with this release of fuse-esb.

      When I shutdonw and restart fuse-esb I found this error inside log file.

       

      08:56:44,692 | DEBUG | rint Extender: 2 | OdeLifeCycle                     | 208 - ode-jbi-bundle - 1.3.5 | Creating data source.

      08:56:44,703 | INFO  | rint Extender: 2 | Database                         | 208 - ode-jbi-bundle - 1.3.5 | Using Embedded Derby: jdbc:derby:C:\amb\apache-servicemix-4.3.1-fuse-01-09\data\jbi\OdeBpelEngine\install/jpadb

      08:56:44,703 | DEBUG | rint Extender: 2 | Database                         | 208 - ode-jbi-bundle - 1.3.5 | Creating connection pool for jdbc:derby:C:\amb\apache-servicemix-4.3.1-fuse-01-09\data\jbi\OdeBpelEngine\install/jpadb with driver org.apache.derby.jdbc.EmbeddedDriver

      08:56:44,703 | ERROR | rint Extender: 2 | OdeLifeCycle                     | 208 - ode-jbi-bundle - 1.3.5 | Database configuration error.

      java.lang.RuntimeException: TransactionManager is not recoverable.

           at org.apache.ode.il.dbutil.Database.initInternalDb(Database.java:180)[208:ode-jbi-bundle:1.3.5]

           at org.apache.ode.il.dbutil.Database.initEmbeddedDb(Database.java:249)[208:ode-jbi-bundle:1.3.5]

           at org.apache.ode.il.dbutil.Database.initDataSource(Database.java:149)[208:ode-jbi-bundle:1.3.5]

           at org.apache.ode.il.dbutil.Database.start(Database.java:100)[208:ode-jbi-bundle:1.3.5]

           at org.apache.ode.jbi.OdeLifeCycle.initDataSource(OdeLifeCycle.java:188)[208:ode-jbi-bundle:1.3.5]

           at org.apache.ode.jbi.OdeLifeCycle.init(OdeLifeCycle.java:126)[208:ode-jbi-bundle:1.3.5]

           at org.apache.servicemix.jbi.deployer.artifacts.ComponentImpl$ComponentWrapper.init(ComponentImpl.

       

      The features installed are:

       

      karaf@root> features:list -i

      State         Version                Name                  Repository

      camel                 repo-0

      camel-core            repo-0

      camel-spring          repo-0

      camel-blueprint       repo-0

      spring                karaf-2.1.4-fuse-00-09

      spring-dm             karaf-2.1.4-fuse-00-09

      config                karaf-2.1.4-fuse-00-09

      http                  karaf-2.1.4-fuse-00-09

      war                   karaf-2.1.4-fuse-00-09

      ode-core-deps         repo-0

      ode-core              repo-0

      ode-jpa-deps          repo-0

      ode-derby-deps        repo-0

      ode                   repo-0

      naming                repo-0

      transaction           repo-0

      document              repo-0

      nmr                   repo-0

      woodstox              repo-0

      jbi                   repo-0

      jbi-cluster           repo-0

      cxf                   repo-0

      servicemix-shared     repo-0

      servicemix-cxf-bc     repo-0

      servicemix-file       repo-0

      servicemix-ftp        repo-0

      servicemix-http       repo-0

      servicemix-jms        repo-0

      servicemix-mail       repo-0

      servicemix-bean       repo-0

      servicemix-camel      repo-0

      servicemix-drools     repo-0

      servicemix-cxf-se     repo-0

      servicemix-eip        repo-0

      servicemix-osworkflow repo-0

      servicemix-quartz     repo-0

      servicemix-scripting  repo-0

      servicemix-validation repo-0

      servicemix-saxon      repo-0

      servicemix-wsn2005    repo-0

      servicemix-snmp       repo-0

      servicemix-vfs        repo-0

      servicemix-smpp       repo-0

      activemq-broker       repo-0

      activemq              activemq-5.4.2-fuse-03-09

      activemq-blueprint    activemq-5.4.2-fuse-03-09

      karaf@root>

       

      can someone help me?

      Thank you

       

      Massimiliano