2 Replies Latest reply on Apr 22, 2011 3:52 AM by Bryan Brouckaert

    Proxy settings in (external) Maven activate proxy in FuseESB

    Bryan Brouckaert Newbie

      Hello,

       

      I just spend about a day looking for this, hope you that I will help somebody with this.

       

      At one point I got HTTP 404 errors when Fuse ESB had to call a web service.  When I finally took out the network sniffer, I quickly noticed the ESB wasn't contacting my server but contacted the proxy.  The explained the HTTP error, since the server is internal.

       

      I had no clue where this config came from, it wasn't in the JDK setting nor in the Fuse ESB settings (or any other directory).  I even deactivated my proxy in windows, nothing helped.

       

      When I attached the debugger (for a different issue) I check the "http.proxyHost" system-property and found that it was set, although I never set it.  A full scan of the Fuse ESB directory did reveal this was indeed the case.

       

      Then I started Fuse ESB with blocking debugger, configured eclipse to break at the set property method (when it contain "proxy" in the argument) and got a hit!

       

      I knew that Fuse ESB uses maven to get its bundles and I should have know that it checks the standard locations for maven configurations but what I could not have known is that it applies the proxy settings for the entire JVM it runs in!  This means all http calls (including the onces from CXF) use this proxy.

       

      So, when you set a proxy for your local maven it also applies to your local FuseESB

       

      I hope to have helped some people with this and I also hope that Fuse ESB will load maven separately or that maven will become more embedded friendly!