0 Replies Latest reply on May 9, 2011 2:16 PM by John Ellinwood

    DOSGi and Servicemix

    John Ellinwood Newbie

      Does DOSGi work on Fuse?  I'm trying to get DOSGi 1.2 running on Fuse 4.3.1 using JDK 6u24.  I posted about this to the DOSGi forum before, but they said its  Fuse issue.  If I could get this combination running at all and prove that it will work for our needs, we'd be willing to purchase support.

       

      I've spent days trying to get this to work, searching forums, etc., and its just not working for me. I really want to get this working so I can use it for a project.  The main problem seems to be with the intent-map.xml loading.

       

      I just installed a clean version of Fuse 4.3.1. Then I installed the OSGi compendium.  Then I installed the single bundle distro of dosgi 1.2.  I get an unresolved dependency on javax.servlet [2.3.0,2.6.0)... even though 2.5 is exported by another bundle.

       

      Then I tried using the multi bundle distro.  I setup the etc/custom.properties with the distribution and discovery settings, and installed all the bundles.  I end up with an error "Line 1 in XML document from OSGI resource /OSGI-INF/cxf/intents/intent-map.xml is invalid. Markup declarations contained or pointed to by the document type declaration

      must be well-formed."  Trying to start a the greeter demo after that results in an NPE saying "TopologyManager.notifyListenerOfAddingIfAppropriate .. No mapping for intent:SOAP".

       

      I've tried the single bundle and multi bundle distros of 1.2 and 1.3-SNAPSHOT on the root servicemix container as well as a child container. I also downloaded the 1.3 source and built it myself. Installed that... same problems.

       

      I tried applying the patch from #DOSGI-69 https://issues.apache.org/jira/browse/DOSGI-69 but then it just says that the intent-map.xml file doesn't exist.

       

      Can somebody help or point me in the right direction?

       

      Thanks,

      John