1 Reply Latest reply on Nov 3, 2004 11:00 AM by azydron

    Stateless Session Bean write fails

    azydron Newbie

      Hi,

      I have a problem using A Stateless Session Bean that writes a record to an Oracle 9i table using a JDBC DS declaration. The write (using an SQL INSERT statement) works fine if the call comes from a non-EJB client using a Helper object. If I use the same Helper object from another Stateless Session Bean the write never works, but I do not get an error message. The environment is:

      Windows XP Home SP1
      JDK 1.4.2_5
      JBoss 3.2.3

      Reads from the database from the EJB always work fine regardless if the client is another EJB or not.

      I have tried all permutations of settings in my ejb-jar.xml etc. and closing connections and PreparedStatements etc.

      Initially both stateless session beans had different transaction types, one DS was described as xa-datasource, the other as a local-tx-datasource. I have changed both to local-tx-datasource, but to no avail.

      The situation is now that if the StatelessSession Bean runs for more that 5 or 6 minutes then the write fails. I have changed the idle-timeout-minutes parameter to everything from 145 minutes to 0 and I still get a transaction timout after about 5 minutes.

      Thanks in advance,

      AZ