4 Replies Latest reply on Jun 7, 2011 8:31 AM by Herve BARRAULT

    fuse 4.3.0-fuse-03-00 distribution does not start

    Herve BARRAULT Newbie

      Hi,

      I have downloaded the fuse 4.3.0-fuse-03-00 distribution (i know it is not the latest one) and i have tried to start it.

       

      But it is not able to start, i have the following log :

       

      10:39:56,888 | ERROR | Thread-6         | FeaturesServiceImpl              | s.internal.FeaturesServiceImpl$1  780 | 21 - org.apache.karaf.features.core - 2.0.0.fuse-02-00 | Error installing boot features

      java.lang.Exception: Could not start bundle mvn:org.apache.xbean/xbean-blueprint/3.7 in feature(s) : The bundle "org.apache.xbean.blueprint_3.7.0 " could not be resolved. Reason: Missing Constraint: Import-Package: org.apache.commons.jexl2; version="2.0.0"

           at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeatures(FeaturesServiceImpl.java:315)[21:org.apache.karaf.features.core:2.0.0.fuse-02-00]

           at org.apache.karaf.features.internal.FeaturesServiceImpl$1.run(FeaturesServiceImpl.java:778)[21:org.apache.karaf.features.core:2.0.0.fuse-02-00]

      Caused by: org.osgi.framework.BundleException: The bundle "org.apache.xbean.blueprint_3.7.0 " could not be resolved. Reason: Missing Constraint: Import-Package: org.apache.commons.jexl2; version="2.0.0"

           at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolverError(AbstractBundle.java:1317)[osgi-3.6.0.v20100517.jar:]

           at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolutionFailureException(AbstractBundle.java:1301)[osgi-3.6.0.v20100517.jar:]

           at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:319)[osgi-3.6.0.v20100517.jar:]

           at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:284)[osgi-3.6.0.v20100517.jar:]

           at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:276)[osgi-3.6.0.v20100517.jar:]

           at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeatures(FeaturesServiceImpl.java:307)[21:org.apache.karaf.features.core:2.0.0.fuse-02-00]

           ... 1 more

       

      If i looked in the system directory i can find a jexl bundle in version 2.0.1 but not in version 2.0.0

       

      I have also noticed another thing which is not starting (the activemq feature).

      This feature needs the bundle mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.howl/1.0.1-1_2

      which is not in the system directory.

       

      Where can i find a well pre-configured distribution of the 4.3.0 branch ?

       

      With the default distribution version 4.3.0-fuse-03-00 is not able to start as the previous version 4.3.0-fuse-02-00 (http://fusesource.com/issues/browse/ESB-1313).

       

      Thanks for answers.

       

      Edited by: tha_hba on Jun 6, 2011 11:13 AM