3 Replies Latest reply on Jun 9, 2011 4:31 AM by Sergey Zhemzhitsky

    camel-groovy feature. Groovy version issue.

    Sergey Zhemzhitsky Newbie

      Hi there,

       

      It seems that there is an issue with camel-groovy feature in the apache-servicemix-4.3.1-fuse-01-09.

       

      Here is the declaration of the feature

      <feature name="camel-groovy" version="2.6.0-fuse-01-09">
          <feature version="2.6.0-fuse-01-09">camel-core</feature>
          <bundle>mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.ant/1.7.0_4</bundle>
          <bundle>mvn:org.apache.servicemix.specs/org.apache.servicemix.specs.scripting-api-1.0/1.7.0</bundle>
          <bundle>mvn:org.codehaus.groovy/groovy-all/1.7.5</bundle>
          <bundle>mvn:org.apache.camel/camel-groovy/2.6.0-fuse-01-09</bundle>
      </feature>
      

      It uses groovy 1.7.5

       

      And here is the version of the groovy from the camel-parent/2.6.0-fuse-01-09 project

      <groovy-version>1.7.7</groovy-version>
      

      So there might be some troubles using maven-bundle-plugin with versionpolicy declared like this

      <_versionpolicy>"[$(version;===;$(@)),$(version;+00;$(@)))"</_versionpolicy>
      

      which requires the version to be at least equal to a version that bundle plugin can determine scanning dependencies.