1 Reply Latest reply on Jun 21, 2011 9:43 PM by Rogelio Sevilla

    Fuse ESB doesn't start

    Rogelio Sevilla Novice

      Hello everyone:

       

      I'm having a strange issue with Fuse ESB. The last 2 days I had been playing around with maven and camel, before that, my Fuse ESB installation was doing ok. The problem is that today, when i wanted to run fuse esb again doing the usual  ./servicemix  ,  I immediately got this error:

       

       

      Exception in thread "main" java.lang.NoClassDefFoundError: :

      Caused by: java.lang.ClassNotFoundException: :

           at java.net.URLClassLoader$1.run(URLClassLoader.java:202)

           at java.security.AccessController.doPrivileged(Native Method)

           at java.net.URLClassLoader.findClass(URLClassLoader.java:190)

           at java.lang.ClassLoader.loadClass(ClassLoader.java:306)

           at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)

           at java.lang.ClassLoader.loadClass(ClassLoader.java:247)

      Could not find the main class: :.  Program will exit.

       

       

      The only thing I did is clean up my local maven repo and rebuild it again. Also, I tried to run a completely fresh install of fuse esb but got the same error. What could be the problem??

       

      P.S : i'm using Fuse ESB 4.3.1