2 Replies Latest reply on Aug 9, 2011 9:29 AM by Nele De Vleeschauwer

    Unsatisfied requirement while activating http-jetty feature

    Nele De Vleeschauwer Novice

      Hi,

       

      I would like to install the http-jetty feature to be able to test inbound http on the Fuse ESB.

      The installation of this feature always fails with the following error:

      14:31:14,258 | INFO  | l Console Thread | FeaturesServiceImpl              | 41 - org.apache.karaf.features.core - 2.2.0.fuse-00-43 | Installing feature camel-jetty 2.7.1-fuse-00-43

      14:31:14,258 | INFO  | l Console Thread | FeaturesServiceImpl              | 41 - org.apache.karaf.features.core - 2.2.0.fuse-00-43 | Installing feature jetty 7.4.1.v20110513

      14:31:14,258 | INFO  | l Console Thread | FeaturesServiceImpl              | 41 - org.apache.karaf.features.core - 2.2.0.fuse-00-43 | Installing feature camel-core 2.7.1-fuse-00-43

      14:31:14,258 | INFO  | l Console Thread | FeaturesServiceImpl              | 41 - org.apache.karaf.features.core - 2.2.0.fuse-00-43 | Installing feature camel-http 2.7.1-fuse-00-43

      14:31:14,305 | INFO  | l Console Thread | Console                          | 38 - org.apache.karaf.shell.console - 2.2.0.fuse-00-43 | Exception caught while executing command

      java.lang.Exception: Can not resolve feature:

      Unsatisfied requirement(s):

      -


         package:(&(package=org.apache.camel.component.http)(version>=2.7.0)(!(version>=2.8.0)))

            camel-jetty

         package:(&(package=org.apache.camel.component.http.helper)(version>=2.7.0)(!(version>=2.8.0)))

            camel-jetty

       

      Does anyone know how I can solve this ?

       

      Edited by: neledv on Aug 9, 2011 12:45 PM