1 Reply Latest reply on Nov 22, 2011 9:48 PM by Freeman(Yue) Fang

    Missing Requirement  Openjpa.enhance

    Malcolm Mallia Newbie



      I was working on janstey-rider-auto-osgi example in the Getting Started with serviceMix webinar.  I changed the backend to store the object in a database using JPA using JPA annotations to the model in the common module and changing the camel route.


      In the serviceMix shell I installed the jpa-hibernate and camel-jpa features.  I then tried to install my example.  I get the following error:


      INFO  | l Console Thread | Console                          | 35 - org.apache.karaf.shell.console - 2.2.2.fuse-00-08 | Exception caught while executing command

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.fusesource.examples.rider-auto-common : Unable to resolve 335.0: missing requirement package; (&(package=org.apache.openjpa.enhance)(version>=2.0.0)(!(version>=3.0.0)))

           at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3455)[org.apache.felix.framework-3.0.9-fuse-01-08.jar:]


      Are there any other missing features I have to install to make JPA work apart from jpa-hibernate and camel-jpa ?





        • 1. Re: Missing Requirement  Openjpa.enhance
          Freeman(Yue) Fang Master



          In the latest Fuse ESB version we ship org.apache.openjpa.enhance; version=1.2.1 if you install camel-jpa, but that example need higher version(version>=2.0.0) of openjpa bundle and java-persistent api 2.0,


          You can do

          osgi:install -s mvn:org.apache.servicemix.specs/org.apache.servicemix.specs.java-persistence-api-2.0/1.8.0


          osgi:install -s mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.openjpa/2.0.0_2


          to make those bundle available.