4 Replies Latest reply on Dec 26, 2011 5:33 AM by Alessio Orlando

    Unrecognized xbean namespace mapping: http://activemq.org/config/1.0

    Alessio Orlando Newbie

      Hi,

      i'm new with fuse service mix. I'm trying to follow a tutorial making me construct a servicemix-jms provider service unit.

      Using

      mvn archetype:create -DarchetypeArtifactId=servicemix-jms-provider-service-unit

          -DarchetypeGroupId=org.apache.servicemix.tooling -DartifactId=tutorial-camel-jms-su

       

      i got an xbean with this list below:

       

           at org.apache.servicemix.common.ManagementSupport.failure(ManagementSupport.java:46)[154:servicemix-common:2011.02.1.fuse-02-11]

           at org.apache.servicemix.common.AbstractDeployer.failure(AbstractDeployer.java:43)[154:servicemix-common:2011.02.1.fuse-02-11]

           at org.apache.servicemix.common.xbean.AbstractXBeanDeployer.deploy(AbstractXBeanDeployer.java:116)[154:servicemix-common:2011.02.1.fuse-02-11]

           at org.apache.servicemix.common.BaseServiceUnitManager.doDeploy(BaseServiceUnitManager.java:86)[154:servicemix-common:2011.02.1.fuse-02-11]

           at org.apache.servicemix.common.BaseServiceUnitManager.deploy(BaseServiceUnitManager.java:69)[154:servicemix-common:2011.02.1.fuse-02-11]

           at org.apache.servicemix.jbi.deployer.artifacts.ServiceUnitImpl.deploy(ServiceUnitImpl.java:104)[150:org.apache.servicemix.jbi.deployer:1.5.1.fuse-01-11]

           at org.apache.servicemix.jbi.deployer.impl.ServiceAssemblyInstaller.deploySUs(ServiceAssemblyInstaller.java:207)[150:org.apache.servicemix.jbi.deployer:1.5.1.fuse-01-11]

           ... 13 more

       

      I use the apache-servicemix-4.4.1-fuse-01-11

      i think it depends of the spring framework (Unrecognized xbean namespace mapping: http://activemq.org/config/1.0)... so what i can do?

       

      Now if i try to replace  http://activemq.org/config/1.0 with the namespace http://activemq.apache.org/schema/core (from this page: http://activemq.apache.org/xml-reference.html) maven build fails telling me  Unrecognized xbean namespace mapping: http://activemq.apache.org/schema/core...

      Any help?

      Alessio