1 Reply Latest reply on Feb 1, 2012 8:56 PM by Freeman(Yue) Fang

    Can't deploy OSGI bundles to Servicemix 4.4.1 Fuse on linux

    Zs H Newbie

      Hi

       

      We run into a very strange problem. We developed some OSGI bundles for Servicemix 4.4.1 Fuse on Windows without any problem. Bundles can be deployed flawlessly. We tried to configure the same environment on linux. After deployment the bundles are active, but they don't run and we are not able to start them by hand (osgi:start). Unfortunatelly we can't see any relevant information in the log. There's no exceptions, errors.

       

      We tried to redeploy bundles couple of times and we also cleaned data directory without success.

       

      There are very rare ocassions when everything works, but we can't figure out when and why. After a successfull deploy, if we shutdown servicemix and start again, nothing works. Bundles are active and not started. We suspect that the problem is linux related but we couldn't found any information about such an issue.

       

      We tried to use Ubuntu 10.10 32bit with sun jdk 1.6.0_26 and CentOS with Open JDK with the same result.

       

      Have you seen such an issue? Do you know any resolution?

       

      Thanks,

       

      Hubi