2 Replies Latest reply on Feb 6, 2012 3:35 PM by Jochen Lauer

    Several "Unresolved constraints" on apache-servicemix-4.4.1-fuse-01-13

    Jochen Lauer Apprentice

      Hello,

       

      I have some trouble with the latest servicemix  apache-servicemix-4.4.1-fuse-01-13 on a linux machine / jdk 1.6_23.

      After the installation I added some camel features.

       

      ERROR: Bundle activemq-broker.xml [72] Error starting blueprint:file:etc/activemq-broker.xml (org.osgi.framework.BundleException: Unresolved constraint in bundle activemq-broker.xml [72]: Unable to resolve 72.0: missing requirement [72.0] package; (package=org.apache.activemq))
      org.osgi.framework.BundleException: Unresolved constraint in bundle activemq-broker.xml [72]: Unable to resolve 72.0: missing requirement [72.0] package; (package=org.apache.activemq)
              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3455)
              at org.apache.felix.framework.Felix.startBundle(Felix.java:1728)
              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1157)
              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)
              at java.lang.Thread.run(Thread.java:662)
      ERROR: Bundle org.apache.camel.camel-http [128] Error starting mvn:org.apache.camel/camel-http/2.8.0-fuse-01-13 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.camel.camel-http [128]: Unable to resolve 128.0: missing requirement [128.0] package; (&(package=org.apache.commons.httpclient)(version>=3.1.0)(!(version>=4.0.0))) [caused by: Unable to resolve 129.0: missing requirement [129.0] package; (&(package=org.apache.commons.codec)(version>=1.3.0)(!(version>=2.0.0)))])
      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.camel.camel-http [128]: Unable to resolve 128.0: missing requirement [128.0] package; (&(package=org.apache.commons.httpclient)(version>=3.1.0)(!(version>=4.0.0))) [caused by: Unable to resolve 129.0: missing requirement [129.0] package; (&(package=org.apache.commons.codec)(version>=1.3.0)(!(version>=2.0.0)))]
              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3455)
              at org.apache.felix.framework.Felix.startBundle(Felix.java:1728)
              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1157)
              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)
              at java.lang.Thread.run(Thread.java:662)
      ERROR: Bundle org.apache.servicemix.bundles.commons-httpclient [129] Error starting mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.commons-httpclient/3.1_6 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.servicemix.bundles.commons-httpclient [129]: Unable to resolve 129.0: missing requirement [129.0] package; (&(package=org.apache.commons.codec)(version>=1.3.0)(!(version>=2.0.0))))
      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.servicemix.bundles.commons-httpclient [129]: Unable to resolve 129.0: missing requirement [129.0] package; (&(package=org.apache.commons.codec)(version>=1.3.0)(!(version>=2.0.0)))
              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3455)
              at org.apache.felix.framework.Felix.startBundle(Felix.java:1728)
              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1157)
              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)
              at java.lang.Thread.run(Thread.java:662)
      ERROR: Bundle org.apache.camel.camel-jetty [130] Error starting mvn:org.apache.camel/camel-jetty/2.8.0-fuse-01-13 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.camel.camel-jetty [130]: Unable to resolve 130.0: missing requirement [130.0] package; (&(package=org.apache.camel.component.http)(version>=2.8.0)(!(version>=2.9.0))) [caused by: Unable to resolve 128.0: missing requirement [128.0] package; (&(package=org.apache.commons.httpclient)(version>=3.1.0)(!(version>=4.0.0))) [caused by: Unable to resolve 129.0: missing requirement [129.0] package; (&(package=org.apache.commons.codec)(version>=1.3.0)(!(version>=2.0.0)))]])
      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.camel.camel-jetty [130]: Unable to resolve 130.0: missing requirement [130.0] package; (&(package=org.apache.camel.component.http)(version>=2.8.0)(!(version>=2.9.0))) [caused by: Unable to resolve 128.0: missing requirement [128.0] package; (&(package=org.apache.commons.httpclient)(version>=3.1.0)(!(version>=4.0.0))) [caused by: Unable to resolve 129.0: missing requirement [129.0] package; (&(package=org.apache.commons.codec)(version>=1.3.0)(!(version>=2.0.0)))]]
              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3455)
              at org.apache.felix.framework.Felix.startBundle(Felix.java:1728)
              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1157)
              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)
              at java.lang.Thread.run(Thread.java:662)
      ERROR: Bundle org.apache.camel.camel-atom [165] Error starting mvn:org.apache.camel/camel-atom/2.8.0-fuse-01-13 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.camel.camel-atom [165]: Unable to resolve 165.0: missing requirement [165.0] package; (&(package=org.apache.abdera)(version>=0.4.0)(!(version>=2.0.0))) [caused by: Unable to resolve 166.0: missing requirement [166.0] package; (&(package=org.apache.abdera.i18n.iri)(version>=1.1.2)(!(version>=1.1.3))) [caused by: Unable to resolve 167.0: missing requirement [167.0] package; (&(package=org.apache.commons.codec)(version>=1.3.0)(!(version>=2.0.0)))]])
      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.camel.camel-atom [165]: Unable to resolve 165.0: missing requirement [165.0] package; (&(package=org.apache.abdera)(version>=0.4.0)(!(version>=2.0.0))) [caused by: Unable to resolve 166.0: missing requirement [166.0] package; (&(package=org.apache.abdera.i18n.iri)(version>=1.1.2)(!(version>=1.1.3))) [caused by: Unable to resolve 167.0: missing requirement [167.0] package; (&(package=org.apache.commons.codec)(version>=1.3.0)(!(version>=2.0.0)))]]
              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3455)
              at org.apache.felix.framework.Felix.startBundle(Felix.java:1728)
              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1157)
              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)
              at java.lang.Thread.run(Thread.java:662)
      ERROR: Bundle org.apache.abdera.core [166] Error starting mvn:org.apache.abdera/abdera-core/1.1.2 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.abdera.core [166]: Unable to resolve 166.0: missing requirement [166.0] package; (&(package=org.apache.abdera.i18n.iri)(version>=1.1.2)(!(version>=1.1.3))) [caused by: Unable to resolve 167.0: missing requirement [167.0] package; (&(package=org.apache.commons.codec)(version>=1.3.0)(!(version>=2.0.0)))])
      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.abdera.core [166]: Unable to resolve 166.0: missing requirement [166.0] package; (&(package=org.apache.abdera.i18n.iri)(version>=1.1.2)(!(version>=1.1.3))) [caused by: Unable to resolve 167.0: missing requirement [167.0] package; (&(package=org.apache.commons.codec)(version>=1.3.0)(!(version>=2.0.0)))]
              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3455)
              at org.apache.felix.framework.Felix.startBundle(Felix.java:1728)
              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1157)
              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)
              at java.lang.Thread.run(Thread.java:662)
      ERROR: Bundle org.apache.abdera.i18n [167] Error starting mvn:org.apache.abdera/abdera-i18n/1.1.2 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.abdera.i18n [167]: Unable to resolve 167.0: missing requirement [167.0] package; (&(package=org.apache.commons.codec)(version>=1.3.0)(!(version>=2.0.0))))
      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.abdera.i18n [167]: Unable to resolve 167.0: missing requirement [167.0] package; (&(package=org.apache.commons.codec)(version>=1.3.0)(!(version>=2.0.0)))
              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3455)
              at org.apache.felix.framework.Felix.startBundle(Felix.java:1728)
              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1157)
              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)
              at java.lang.Thread.run(Thread.java:662)
      ERROR: Bundle org.apache.servicemix.bundles.velocity [66] Error starting mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.velocity/1.7_1 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.servicemix.bundles.velocity [66]: Unable to resolve 66.0: missing requirement [66.0] package; (&(package=org.apache.commons.collections)(version>=3.2.0)(!(version>=4.0.0))))
      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.servicemix.bundles.velocity [66]: Unable to resolve 66.0: missing requirement [66.0] package; (&(package=org.apache.commons.collections)(version>=3.2.0)(!(version>=4.0.0)))
              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3455)
              at org.apache.felix.framework.Felix.startBundle(Felix.java:1728)
              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1157)
              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)
              at java.lang.Thread.run(Thread.java:662)
                
      

       

      How can I resolve all required dependencies ?

       

      Thanks

      labo