1 Reply Latest reply on Feb 1, 2012 9:36 PM by Freeman(Yue) Fang

    Unable to install webconsole or activemq webconsole in linux

    Thomas Peters Newbie

      I am getting following error while installing features for webconsole and activemq webconsole. I am pointing to local repository which is copied from working environment in windows.

       

      -- features:install activemq-web-console

      Error executing command: URL mvn:org.apache.activemq/activemq-web-console/5.5.1-fuse-01-13/war?Webapp-Context=activemq-web-console could not be resolved.

       

      -- features:install webconsole-base

      Error executing command: URL mvn:org.apache.felix/org.apache.felix.metatype/1.0.4 could not be resolved.

        • 1. Re: Unable to install webconsole or activemq webconsole in linux
          Freeman(Yue) Fang Master

          Hi,

           

          This error means your local repo doesn't have the required artifacts like

          mvn:org.apache.activemq/activemq-web-console/5.5.1-fuse-01-13/war

          and

          mvn:org.apache.felix/org.apache.felix.metatype/1.0.4

           

          You need have internet connection or download the required artifacts manually and copy it  to your local repo.

           

          Btw, the local repo working in windows doesn't means it has the required artifacts.

           

          pax-url-mvn not like stand alone maven, it only download required remote artifacts to bundle cache but not to the local repo.

           

          Freeman