3 Replies Latest reply on May 20, 2012 3:36 AM by Claus Ibsen

    Problem with jetty & javamail running camel under tomcat

    Julian Cable Newbie

      I'm using Apache Camel to deliver a file as an email attachment. It works perfectly using the following maven goals:






      I'm using java 1.6. My deployment container is tomcat6. In tomcat6 and tomcat7 I get the following exception:


      org.springframework.mail.MailSendException: Failed messages: javax.mail.MessagingException: Missing start boundary; message exception details (1) are:

      Failed message 1:

      javax.mail.MessagingException: Missing start boundary

      at javax.mail.internet.MimeMultipart.parsebm(MimeMultipart.java:882)


      The advice on the web suggests this is a class loader problem. Its either that the activation-1.1.jar or mail-1.4.4.jar files are not being found, or the mailcap file in mail-1.4.4.jar is not being found.


      I've tried putting these jar files in tomcat/lib. I've tried copying the mailcap from the jar file into the META-INF directory of the exploded war. Neither of these make a difference.




      Windows: Apache Tomcat/7.0.5 JDK 1.6.0_27-b07 Apache Camel 2.8.0-fuse-00-08


      Linux - the versions that come with ubuntu 10.04 LTS.


      This is a simplified version of my camel routes:


          [4 - seda://mail-ws-audio-files] mail                           INFO  Exchange[ExchangePattern:InOut, Headers:{Connection=Keep-Alive, CamelHttpServletRequest=org.eclipse.jetty.servlets.MultiPartFilter$Wrapper@bb32c5, upfile=D:downloads!37SQFTS.pdf, CamelHttpPath=/fup, subject=BBC Premier League Update - Edition 1, CamelHttpQuery=null, CamelHttpServletResponse=HTTP/1.1 200


      , UntilMessage=until 10:30 GMT when a second bulletin is available (Mon-Fri only), Host=localhost:9095, User-Agent=Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; .NET4.0C; .NET4.0E), Accept-Encoding=gzip, deflate, bulletin_type=am, to=julian.cable@yahoo.com, cc=admin@localhost, breadcrumbId=ID-B1-L0N336601-58958-1335935026761-0-2, CamelHttpUrl=http://localhost:9095/fup, Content-Length=24896, Referer=http://localhost:9095/premier, from=jfbcable@gmail.com, Accept=image/jpeg, application/x-ms-application, image/gif, application/xaml+xml, image/pjpeg, application/x-ms-xbap, application/vnd.ms-excel, application/vnd.ms-powerpoint, application/msword, /, Accept-Language=en-GB, Content-Type=multipart/form-data; boundary=----

      7dc3a8371906f6, CamelHttpUri=/fup, Cache-Control=no-cache, CamelHttpMethod=POST}, BodyType:String, Body:Dear Partner,


           please find attached the latest edition of our file.



      A minimal example maven project is  here and the war is here. If you run the project in eclipse or with


          mvn jetty:run


      and then use the form at http://localhost:9095/premier


      You will get a "cannot contact server" exception. But if you deploy the war to tomcat you will get the missing start boundary exception. If you edit applicationContext.xml and replace the **** with valid values, it will actually send an email.



      Any ideas?