2 Replies Latest reply on Jun 25, 2012 4:36 AM by paul berry

    Can't connect to activemq from remote host?

    paul berry Newbie

      Hi,

       

      I have Fuse ESB running on a fedora box, and also have another isntance running on my windows desktop.  I'm unable to connect from a route on my windows box to activemq running on the fedora box.

       

      I've tried telnetting to the fedora box, and get 'connection refused'.  On localhost (ie: from the console on the fedora box) telnet connects fine.

       

      I've edited /etc/activemq-broker.xml and changed the definition of the 'openwire' transport connector from:

       

       

       

      with no change.

       

      Firewall on both machines is disabled.

       

      Edited by: paul.berry on Jun 22, 2012 2:15 PM

        • 1. Re: Can't connect to activemq from remote host?
          Gert Vanthienen Novice

          L.S.,

           

          Not sure which version of Fuse ESB you're using, but in most versions, the activemq-broker.xml file changes are not automatically deployed.  In order to restart the broker with the new settings, you would have to do an osgi:update  for the activemq-broker.xml file.  You can also stop the container and delete the data folder to ensure those changes get picked up.

           

          Afterwards, on your Linux machine, you can use the netstat command to verify that the connector is actually listening on all interfaces and not only on 127.0.0.1 (using something like netstat -an | grep 61616)

           

          Regards,

           

          Gert

          • 2. Re: Can't connect to activemq from remote host?
            paul berry Newbie

            Thanks gert, I'd restarted servicemix but didn't realise I had to delete the data folder as well.

             

            All is working now, many thanks.

             

            Paul.