0 Replies Latest reply on Jun 25, 2012 7:50 AM by Radomír Kadlec

    How to use saxon:proxy xslt with params?

    Radomír Kadlec Newbie

      Hello,

       

      When I use my xslt resource with parameters from the  example  together with saxon:xslt, allways is correct and parameters are used.

       

      But wehen I tried to use the same xslt resource together with the saxon:proxy endpoint, this error occurs:

       

      09:54:31,043 | ERROR | ovider-thread-13 | DefaultComponent                 | 159 - servicemix-common - 2011.2.1.fuse-06-03 | Error processing exchange org.apache.servicemix.jbi.runtime.impl.InOnlyImpl@be1ab3

      net.sf.saxon.trans.XPathException: A value must be supplied for parameter $in because there is no default value for the required type

      at net.sf.saxon.instruct.GlobalParam.evaluateVariable(GlobalParam.java:56)221:org.apache.servicemix.bundles.saxon:9.1.0.8_1

       

      The params are definet as:

      <xsl:param name="exchange" as="class:javax.jbi.messaging.MessageExchange"/>

      <xsl:param name="in" as="class:javax.jbi.messaging.NormalizedMessage"/>

       

      Part of my spring configuration:

      <saxon:xslt

      service="isl-a:IslAWebService"

      endpoint="xquery"

      resource="classpath:xslt/isl-a.fakturaResponse_params.xml"

      />

       

      <saxon:proxy

      service="isl-a:IslAWebService"

      endpoint="xqueryUser"

      resource="classpath:xslt/isl-a.fakturaResponse_params.xml"

       

      Is it possible to use xslt params in the saxon:proxy endpoint?

       

      We use apache-servicemix-4.4.1-fuse-06-03 with osgi deployment.

       

      Thank you for any tips.

      Radomir

       

      Edited by: kadlec on Jun 25, 2012 8:16 AM

       

      Edited by: kadlec on Jun 25, 2012 11:49 AM