4 Replies Latest reply on Sep 28, 2012 2:10 PM by Eric Bender

    Upgrading to camel 2.9

    Eric Bender Newbie

      Hi guys, I have a question regarding upgrading to try out some of the camel 2.9 features within my current servicemix install.  I would think all I need to do is add the features repo xml to the list, and then install components as I need.  The issue I am having is I am not sure how I determine what versions of the repo xmls are out there.

       

      I tried referencing mvn:org.apache.camel.karaf/apache-camel/2.9.0.fuse-70-084/xml/features which didn't seem to work, so I was wondering what repo url I would want to use, or even better, where I can find a list of them or the best way to figure this out.

       

      Thanks!

        • 1. Re: Upgrading to camel 2.9
          Eric Bender Newbie

          Actually I did manage to stumple upon the correct version and now have all of camel 2.9.0 available for feature installation.  Upon attempting to features:install camel-core 2.9.0.fuse-70-084 it does seem that a dependency is missing.  Can anyone help with how to install this missing dependency?

           

          karaf@root> features:install camel-core 2.9.0.fuse-70-084

          Error executing command: Can not resolve feature:

          Unsatisfied requirement(s):

          -


             package:(&(package=jline.console.completer)(version>=2.6.0)(!(version>=3.0.0)))

                camel-karaf-commands

          • 2. Re: Upgrading to camel 2.9
            Freeman(Yue) Fang Master

            Hi,

             

            Package jline.console.completer is exported by a karaf bundle, and this error means what camel want mismatch with the karaf can provide, that said the karaf version you are using can't support camel 2.9.x you want to use.

            It's a general issue when you try upgrade cxf/camel yourself, a lot of dependency get involved and sort all those out isn't a simple task.

             

            Why not try with latest FUSE ESB 7.0.x which already support Camel 2.9.x OOTB?

             

            Freeman

            • 3. Re: Upgrading to camel 2.9
              Eric Bender Newbie

              Trying that now. We have a lot of support infrastructure setup around the existing 4.4.1 installs, but I'll test it out and see how similar it is.

               

              I am running into an issue when installing Enterprise 7 it seems, that once it loads the karaf.bat it hangs at "Please wait while Fuse ESB is loading...".  I am wondering if this has something to do with the user required to install the application, as I am unsure if the box I am using to install has user creation permissions.  Is there a way around this?  I generally don't like installers and prefer the unpack and configure method.

              • 4. Re: Upgrading to camel 2.9
                Eric Bender Newbie

                Found the binary, I'll use that instead.