3 Replies Latest reply on Jan 15, 2013 9:14 AM by Claus Ibsen

    Error starting fuse 4.4.1

    Stéphane Pain Newbie

      Hello, i downloaded apache-servicemix-4.4.1-fuse-08-15 today and when i launch service mix with the start.bat i have the error below. Any idea of the problem ?

       

      Thanks

       

      ERROR: Error parsing system bundle export statement: org.osgi.framework; version=1.5.0, org.osgi.framework.launch; versio

      n=1.0.0, org.osgi.framework.hooks.service; version=1.0.0, org.osgi.service.packageadmin; version=1.2.0, org.osgi.service.

      startlevel; version=1.1.0, org.osgi.service.url; version=1.0.0, org.osgi.util.tracker; version=1.4.0, org.apache.karaf.ja

      as.boot; version=2.2.2.fuse-08-15, org.apache.karaf.version; version=2.2.2.fuse-08-15, ,org.apache.karaf.branding, com.su

      n.org.apache.xalan.internal.xsltc.trax, com.sun.org.apache.xerces.internal.dom, com.sun.org.apache.xerces.internal.jaxp,

      com.sun.org.apache.xerces.internal.xni, com.sun.jndi.ldap, org.apache.xalan.extensions; version="2.7.1", org.apache.xalan

      .xsltc.compiler; version="2.7.1", org.apache.xalan.xsltc.cmdline.getopt; version="2.7.1", org.apache.xalan.xsltc.util; ve

      rsion="2.7.1", org.apache.xalan.transformer; version="2.7.1", org.apache.xalan.xsltc.trax; version="2.7.1", org.apache.xa

      lan.processor; version="2.7.1", org.apache.xalan.lib; version="2.7.1", org.apache.xalan.trace; version="2.7.1", org.apach

      e.xalan.xsltc.compiler.util; version="2.7.1", org.apache.xalan.templates; version="2.7.1", org.apache.xalan.xsltc; versio

      n="2.7.1", org.apache.xalan.xsltc.runtime; version="2.7.1", org.apache.xalan; version="2.7.1", org.apache.xalan.xslt; ver

      sion="2.7.1", org.apache.xalan.lib.sql; version="2.7.1", org.apache.xalan.xsltc.runtime.output; version="2.7.1", org.apac

      he.xalan.xsltc.dom; version="2.7.1", org.apache.xalan.client; version="2.7.1", org.apache.xalan.xsltc.cmdline; version="2

      .7.1", org.apache.xalan.serialize; version="2.7.1", org.apache.xalan.res; version="2.7.1", org.apache.xml.dtm.ref; versio

      n="2.7.1", org.apache.xml.dtm; version="2.7.1", org.apache.xml.dtm.ref.sax2dtm; version="2.7.1", org.apache.xml.dtm.ref.d

      om2dtm; version="2.7.1", org.apache.xml.res; version="2.7.1", org.apache.xml.serializer.dom3; version="2.7.1", org.apache

      .xml.serializer; version="2.7.1", org.apache.xml.serializer.utils; version="2.7.1", org.apache.xml.utils.res; version="2.

      7.1", org.apache.xml.utils; version="2.7.1", org.apache.xpath.functions; version="2.7.1", org.apache.xpath.jaxp; version=

      "2.7.1", org.apache.xpath.patterns; version="2.7.1", org.apache.xpath.objects; version="2.7.1", org.apache.xpath.res; ver

      sion="2.7.1", org.apache.xpath; version="2.7.1", org.apache.xpath.axes; version="2.7.1", org.apache.xpath.compiler; versi

      on="2.7.1", org.apache.xpath.operations; version="2.7.1", org.apache.xpath.domapi; version="2.7.1", org.apache.html.dom;

      version="2.11.0", org.apache.wml.dom; version="2.11.0", org.apache.wml; version="2.11.0", org.apache.xerces.parsers; vers

      ion="2.11.0", org.apache.xerces.impl.dtd.models; version="2.11.0", org.apache.xerces.xni.parser; version="2.11.0", org.ap

      ache.xerces.impl.dv.xs; version="2.11.0", org.apache.xerces.impl.xs.traversers; version="2.11.0", org.apache.xerces.util;

      version="2.11.0", org.apache.xerces.impl.dtd; version="2.11.0", org.apache.xerces.jaxp.validation; version="2.11.0", org

      .apache.xerces.dom3.as; version="2.11.0", org.apache.xerces.impl.dv; version="2.11.0", org.apache.xerces.jaxp; version="2

      .11.0", org.apache.xerces.jaxp.datatype; version="2.11.0", org.apache.xerces.impl.xpath.regex; version="2.11.0", org.apac

      he.xerces.xni; version="2.11.0", org.apache.xerces.impl.msg; version="2.11.0", org.apache.xerces.impl.dv.util; version="2

      .11.0", org.apache.xerces.impl.xs.util; version="2.11.0", org.apache.xerces.dom; version="2.11.0", org.apache.xerces.dom.

      events; version="2.11.0", org.apache.xerces.impl.xs.opti; version="2.11.0", org.apache.xerces.impl; version="2.11.0", org

      .apache.xerces.xs; version="2.11.0", org.apache.xerces.impl.io; version="2.11.0", org.apache.xerces.xpointer; version="2.

      11.0", org.apache.xerces.impl.dv.dtd; version="2.11.0", org.apache.xerces.xinclude; version="2.11.0", org.apache.xerces.i

      mpl.xpath; version="2.11.0", org.apache.xerces.xs.datatypes; version="2.11.0", org.apache.xerces.impl.xs.identity; versio

      n="2.11.0", org.apache.xerces.impl.xs.models; version="2.11.0", org.apache.xerces.xni.grammars; version="2.11.0", org.apa

      che.xerces.impl.xs; version="2.11.0", org.apache.xerces.impl.validation; version="2.11.0", org.apache.xml.serialize; vers

      ion="2.11.0" (java.lang.IllegalArgumentException: No paths specified in header: )

      java.lang.IllegalArgumentException: No paths specified in header:

              at org.apache.felix.framework.util.manifestparser.ManifestParser.parseStandardHeaderClause(ManifestParser.java:14

      32)

              at org.apache.felix.framework.util.manifestparser.ManifestParser.parseStandardHeader(ManifestParser.java:1400)

              at org.apache.felix.framework.util.manifestparser.ManifestParser.(Felix.java:385)

              at org.apache.felix.framework.FrameworkFactory.newFramework(FrameworkFactory.java:28)

              at org.apache.karaf.main.Main.launch(Main.java:265)

              at org.apache.karaf.main.Main.main(Main.java:426)

      ERROR: Bundle org.ops4j.pax.url.wrap Error starting mvn:org.ops4j.pax.url/pax-url-wrap/1.2.6.fuse-01 (org.osgi.framew

      ork.BundleException: Unresolved constraint in bundle org.ops4j.pax.url.wrap : Unable to resolve 1.0: missing requireme

      nt package; (package=javax.net.ssl))

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.ops4j.pax.url.wrap : Unable to resolve 1.0: mi

      ssing requirement package; (package=javax.net.ssl)

              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3531)

              at org.apache.felix.framework.Felix.startBundle(Felix.java:1804)

              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1233)

              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)

              at java.lang.Thread.run(Thread.java:722)

      ERROR: Bundle org.ops4j.pax.url.mvn Error starting mvn:org.ops4j.pax.url/pax-url-mvn/1.2.6.fuse-01 (org.osgi.framewor

      k.BundleException: Unresolved constraint in bundle org.ops4j.pax.url.mvn : Unable to resolve 2.0: missing requirement

      package; (package=javax.net.ssl))

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.ops4j.pax.url.mvn : Unable to resolve 2.0: mis

      sing requirement package; (package=javax.net.ssl)

              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3531)

              at org.apache.felix.framework.Felix.startBundle(Felix.java:1804)

              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1233)

              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)

              at java.lang.Thread.run(Thread.java:722)

      ERROR: Bundle org.ops4j.pax.logging.pax-logging-service Error starting mvn:org.ops4j.pax.logging/pax-logging-service/

      1.6.8 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.ops4j.pax.logging.pax-logging-service :

      Unable to resolve 3.0: missing requirement package; (package=javax.xml.parsers))

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.ops4j.pax.logging.pax-logging-service : Unable

      to resolve 3.0: missing requirement package; (package=javax.xml.parsers)

              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3531)

              at org.apache.felix.framework.Felix.startBundle(Felix.java:1804)

              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1233)

              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)

              at java.lang.Thread.run(Thread.java:722)

      ERROR: Bundle org.ops4j.pax.logging.pax-logging-api Error starting mvn:org.ops4j.pax.logging/pax-logging-api/1.6.8 (o

      rg.osgi.framework.BundleException: Unresolved constraint in bundle org.ops4j.pax.logging.pax-logging-api : Unable to r

      esolve 4.0: missing requirement package; (package=javax.xml.parsers))

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.ops4j.pax.logging.pax-logging-api : Unable to

      resolve 4.0: missing requirement package; (package=javax.xml.parsers)

              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3531)

              at org.apache.felix.framework.Felix.startBundle(Felix.java:1804)

              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1233)

              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)

              at java.lang.Thread.run(Thread.java:722)

      ERROR: Bundle org.apache.felix.configadmin Error starting mvn:org.apache.felix/org.apache.felix.configadmin/1.2.8-fus

      e-09-15 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.felix.configadmin : Unable to

      resolve 5.0: missing requirement package; (package=javax.security.auth))

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.felix.configadmin : Unable to resolve 5

      .0: missing requirement package; (package=javax.security.auth)

              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3531)

              at org.apache.felix.framework.Felix.startBundle(Felix.java:1804)

              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1233)

              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)

              at java.lang.Thread.run(Thread.java:722)

      ERROR: Bundle org.apache.felix.bundlerepository Error starting mvn:org.apache.felix/org.apache.felix.bundlerepository

      /1.6.4 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.felix.bundlerepository : Unable

      to resolve 6.0: missing requirement package; (&(package=org.osgi.framework)(version>=1.3.0)(!(version>=2.0.0))))

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.felix.bundlerepository : Unable to reso

      lve 6.0: missing requirement package; (&(package=org.osgi.framework)(version>=1.3.0)(!(version>=2.0.0)))

              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3531)

              at org.apache.felix.framework.Felix.startBundle(Felix.java:1804)

              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1233)

              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)

              at java.lang.Thread.run(Thread.java:722)

      ERROR: Bundle org.apache.felix.fileinstall Error starting mvn:org.apache.felix/org.apache.felix.fileinstall/3.3.1-fus

      e-08-15 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.felix.fileinstall : Unable to

      resolve 7.0: missing requirement package; (&(package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0))))

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.felix.fileinstall : Unable to resolve 7

      .0: missing requirement package; (&(package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0)))

              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3531)

              at org.apache.felix.framework.Felix.startBundle(Felix.java:1804)

              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1233)

              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)

              at java.lang.Thread.run(Thread.java:722)

      ERROR: Bundle org.apache.aries.proxy Error starting mvn:org.apache.aries.proxy/org.apache.aries.proxy/0.3 (org.osgi.f

      ramework.BundleException: Unresolved constraint in bundle org.apache.aries.proxy : Unable to resolve 8.0: missing requ

      irement package; (&(package=org.apache.aries.util)(version>=0.3.0)(!(version>=1.0.0))) [caused by: Unable to resolv

      e 9.0: missing requirement package; (&(package=org.osgi.framework)(version>=1.5.0)(!(version>=2.0.0)))])

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.proxy : Unable to resolve 8.0: mi

      ssing requirement package; (&(package=org.apache.aries.util)(version>=0.3.0)(!(version>=1.0.0))) [caused by: Unable

      to resolve 9.0: missing requirement package; (&(package=org.osgi.framework)(version>=1.5.0)(!(version>=2.0.0)))]

              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3531)

              at org.apache.felix.framework.Felix.startBundle(Felix.java:1804)

              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1233)

              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)

              at java.lang.Thread.run(Thread.java:722)

      ERROR: Bundle org.apache.aries.util Error starting mvn:org.apache.aries/org.apache.aries.util/0.3.1.fuse-08-15 (org.o

      sgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.util : Unable to resolve 9.0: missing

      requirement package; (&(package=org.osgi.framework)(version>=1.5.0)(!(version>=2.0.0))))

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.util : Unable to resolve 9.0: mis

      sing requirement package; (&(package=org.osgi.framework)(version>=1.5.0)(!(version>=2.0.0)))

              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3531)

              at org.apache.felix.framework.Felix.startBundle(Felix.java:1804)

              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1233)

              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)

              at java.lang.Thread.run(Thread.java:722)

      ERROR: Bundle org.apache.aries.blueprint Error starting mvn:org.apache.aries.blueprint/org.apache.aries.blueprint/0.

      3.1.fuse-08-15 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.blueprint : Unab

      le to resolve 11.0: missing requirement package; (package=javax.xml.parsers))

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.blueprint : Unable to resolve 11

      .0: missing requirement package; (package=javax.xml.parsers)

              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3531)

              at org.apache.felix.framework.Felix.startBundle(Felix.java:1804)

              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1233)

              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)

              at java.lang.Thread.run(Thread.java:722)

      ERROR: Bundle org.apache.aries.jmx.blueprint Error starting mvn:org.apache.aries.jmx/org.apache.aries.jmx.blueprint/

      0.3.1.fuse-08-15 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.jmx.blueprint

      : Unable to resolve 12.0: missing requirement package; (package=javax.management))

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.jmx.blueprint : Unable to resolv

      e 12.0: missing requirement package; (package=javax.management)

              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3531)

              at org.apache.felix.framework.Felix.startBundle(Felix.java:1804)

              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1233)

              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)

              at java.lang.Thread.run(Thread.java:722)

      ERROR: Bundle org.apache.karaf.shell.packages Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.packa

      ges/2.2.2-fuse-08-15 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.packages

      : Unable to resolve 13.0: missing requirement package; (&(package=org.apache.felix.gogo.commands)(version>=0.

      10.0)(!(version>=1.0.0))) [caused by: Unable to resolve 20.0: missing requirement package; (package=javax.security

      .auth)])

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.packages : Unable to resol

      ve 13.0: missing requirement package; (&(package=org.apache.felix.gogo.commands)(version>=0.10.0)(!(version>=1.0.0

      ))) [caused by: Unable to resolve 20.0: missing requirement package; (package=javax.security.auth)]

              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3531)

              at org.apache.felix.framework.Felix.startBundle(Felix.java:1804)

              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1233)

              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)

              at java.lang.Thread.run(Thread.java:722)

      ERROR: Bundle org.apache.karaf.deployer.blueprint Error starting mvn:org.apache.karaf.deployer/org.apache.karaf.depl

      oyer.blueprint/2.2.2-fuse-08-15 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.dep

      loyer.blueprint : Unable to resolve 14.0: missing requirement package; (package=javax.xml.parsers))

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.deployer.blueprint : Unable to r

      esolve 14.0: missing requirement package; (package=javax.xml.parsers)

              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3531)

              at org.apache.felix.framework.Felix.startBundle(Felix.java:1804)

              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1233)

              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)

              at java.lang.Thread.run(Thread.java:722)

      ERROR: Bundle org.apache.karaf.admin.command Error starting mvn:org.apache.karaf.admin/org.apache.karaf.admin.comman

      d/2.2.2-fuse-08-15 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.admin.command [1

      5]: Unable to resolve 15.0: missing requirement package; (package=javax.management))

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.admin.command : Unable to resolv

      e 15.0: missing requirement package; (package=javax.management)

              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3531)

              at org.apache.felix.framework.Felix.startBundle(Felix.java:1804)

              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1233)

              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)

              at java.lang.Thread.run(Thread.java:722)

      ERROR: Bundle org.apache.karaf.shell.dev Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.dev/2.2.2-

      fuse-08-15 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.dev : Unable t

      o resolve 16.0: missing requirement package; (package=javax.net.ssl))

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.dev : Unable to resolve 16

      .0: missing requirement package; (package=javax.net.ssl)

              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3531)

              at org.apache.felix.framework.Felix.startBundle(Felix.java:1804)

              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1233)

              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)

              at java.lang.Thread.run(Thread.java:722)

      ERROR: Bundle org.apache.aries.jmx Error starting mvn:org.apache.aries.jmx/org.apache.aries.jmx/0.3.1.fuse-08-15 (or

      g.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.jmx : Unable to resolve 17.0: miss

      ing requirement package; (package=javax.management))

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.jmx : Unable to resolve 17.0: mi

      ssing requirement package; (package=javax.management)

              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3531)

              at org.apache.felix.framework.Felix.startBundle(Felix.java:1804)

              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1233)

              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)

              at java.lang.Thread.run(Thread.java:722)

      ERROR: Bundle org.apache.karaf.shell.ssh Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.ssh/2.2.2-

      fuse-08-15 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.ssh : Unable t

      o resolve 18.0: missing requirement package; (package=javax.security.auth))

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.ssh : Unable to resolve 18

      .0: missing requirement package; (package=javax.security.auth)

              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3531)

              at org.apache.felix.framework.Felix.startBundle(Felix.java:1804)

              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1233)

              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)

              at java.lang.Thread.run(Thread.java:722)

      ERROR: Bundle org.apache.karaf.features.management Error starting mvn:org.apache.karaf.features/org.apache.karaf.fea

      tures.management/2.2.2-fuse-08-15 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.f

      eatures.management : Unable to resolve 19.0: missing requirement package; (package=javax.management))

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.features.management : Unable to

      resolve 19.0: missing requirement package; (package=javax.management)

              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3531)

              at org.apache.felix.framework.Felix.startBundle(Felix.java:1804)

              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1233)

              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)

              at java.lang.Thread.run(Thread.java:722)

      ERROR: Bundle org.apache.karaf.shell.console Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.consol

      e/2.2.2-fuse-08-15 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.console [2

      0]: Unable to resolve 20.0: missing requirement package; (package=javax.security.auth))

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.console : Unable to resolv

      e 20.0: missing requirement package; (package=javax.security.auth)

              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3531)

              at org.apache.felix.framework.Felix.startBundle(Felix.java:1804)

              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1233)

              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)

              at java.lang.Thread.run(Thread.java:722)

      ERROR: Bundle sshd-core Error starting mvn:org.apache.sshd/sshd-core/0.5.0 (org.osgi.framework.BundleException: Unre

      solved constraint in bundle sshd-core : Unable to resolve 21.0: missing requirement package; (package=javax.cr

      ypto))

      org.osgi.framework.BundleException: Unresolved constraint in bundle sshd-core : Unable to resolve 21.0: missing requi

      rement package; (package=javax.crypto)

              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3531)

              at org.apache.felix.framework.Felix.startBundle(Felix.java:1804)

              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1233)

              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)

              at java.lang.Thread.run(Thread.java:722)

      ERROR: Bundle org.apache.karaf.deployer.spring Error starting mvn:org.apache.karaf.deployer/org.apache.karaf.deploye

      r.spring/2.2.2-fuse-08-15 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.deployer.

      spring : Unable to resolve 22.0: missing requirement package; (package=javax.xml.parsers))

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.deployer.spring : Unable to reso

      lve 22.0: missing requirement package; (package=javax.xml.parsers)

              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3531)

              at org.apache.felix.framework.Felix.startBundle(Felix.java:1804)

              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1233)

              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)

              at java.lang.Thread.run(Thread.java:722)

      ERROR: Bundle org.apache.karaf.jaas.config Error starting mvn:org.apache.karaf.jaas/org.apache.karaf.jaas.config/2.2

      .2-fuse-08-15 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.jaas.config : Una

      ble to resolve 23.0: missing requirement package; (package=javax.net.ssl))

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.jaas.config : Unable to resolve

      23.0: missing requirement package; (package=javax.net.ssl)

              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3531)

              at org.apache.felix.framework.Felix.startBundle(Felix.java:1804)

              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1233)

              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)

              at java.lang.Thread.run(Thread.java:722)

      ERROR: Bundle org.apache.karaf.shell.commands Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.comma

      nds/2.2.2-fuse-08-15 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.commands

      : Unable to resolve 24.0: missing requirement package; (&(package=jline)(version>=2.5.0)(!(version>=3.0.0)))

      [caused by: Unable to resolve 20.0: missing requirement package; (package=javax.security.auth)])

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.commands : Unable to resol

      ve 24.0: missing requirement package; (&(package=jline)(version>=2.5.0)(!(version>=3.0.0))) [caused by: Unable to

      resolve 20.0: missing requirement package; (package=javax.security.auth)]

              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3531)

              at org.apache.felix.framework.Felix.startBundle(Felix.java:1804)

              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1233)

              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)

              at java.lang.Thread.run(Thread.java:722)

      ERROR: Bundle org.apache.karaf.diagnostic.common Error starting mvn:org.apache.karaf.diagnostic/org.apache.karaf.dia

      gnostic.common/2.2.2-fuse-08-15 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.dia

      gnostic.common : Unable to resolve 25.0: missing requirement package; (&(package=org.apache.karaf.features)(ve

      rsion>=2.2.0)(!(version>=3.0.0))) [caused by: Unable to resolve 32.0: missing requirement package; (package=javax.

      management)])

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.diagnostic.common : Unable to re

      solve 25.0: missing requirement package; (&(package=org.apache.karaf.features)(version>=2.2.0)(!(version>=3.0.0)))

      [caused by: Unable to resolve 32.0: missing requirement package; (package=javax.management)]

              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3531)

              at org.apache.felix.framework.Felix.startBundle(Felix.java:1804)

              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1233)

              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)

              at java.lang.Thread.run(Thread.java:722)

      ERROR: Bundle org.apache.karaf.admin.core Error starting mvn:org.apache.karaf.admin/org.apache.karaf.admin.core/2.2.

      2-fuse-08-15 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.admin.core : Unabl

      e to resolve 26.0: missing requirement package; (package=javax.management))

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.admin.core : Unable to resolve 2

      6.0: missing requirement package; (package=javax.management)

              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3531)

              at org.apache.felix.framework.Felix.startBundle(Felix.java:1804)

              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1233)

              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)

              at java.lang.Thread.run(Thread.java:722)

      ERROR: Bundle org.apache.karaf.features.command Error starting mvn:org.apache.karaf.features/org.apache.karaf.featur

      es.command/2.2.2-fuse-08-15 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.feature

      s.command : Unable to resolve 28.0: missing requirement package; (package=javax.management))

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.features.command : Unable to res

      olve 28.0: missing requirement package; (package=javax.management)

              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3531)

              at org.apache.felix.framework.Felix.startBundle(Felix.java:1804)

              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1233)

              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)

              at java.lang.Thread.run(Thread.java:722)

      ERROR: Bundle org.apache.karaf.deployer.kar Error starting mvn:org.apache.karaf.deployer/org.apache.karaf.deployer.k

      ar/2.2.2-fuse-08-15 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.deployer.kar [2

      9]: Unable to resolve 29.0: missing requirement package; (package=javax.xml.parsers))

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.deployer.kar : Unable to resolve

      29.0: missing requirement package; (package=javax.xml.parsers)

              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3531)

              at org.apache.felix.framework.Felix.startBundle(Felix.java:1804)

              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1233)

              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)

              at java.lang.Thread.run(Thread.java:722)

      ERROR: Bundle org.apache.karaf.shell.osgi Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.osgi/2.2.

      2-fuse-08-15 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.osgi : Unabl

      e to resolve 30.0: missing requirement package; (&(package=jline)(version>=2.5.0)(!(version>=3.0.0))) [caused by:

      Unable to resolve 20.0: missing requirement package; (package=javax.security.auth)])

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.osgi : Unable to resolve 3

      0.0: missing requirement package; (&(package=jline)(version>=2.5.0)(!(version>=3.0.0))) [caused by: Unable to reso

      lve 20.0: missing requirement package; (package=javax.security.auth)]

              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3531)

              at org.apache.felix.framework.Felix.startBundle(Felix.java:1804)

              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1233)

              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)

              at java.lang.Thread.run(Thread.java:722)

      ERROR: Bundle org.apache.karaf.jaas.modules Error starting mvn:org.apache.karaf.jaas/org.apache.karaf.jaas.modules/2

      .2.2-fuse-08-15 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.jaas.modules :

      Unable to resolve 31.0: missing requirement package; (package=javax.naming))

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.jaas.modules : Unable to resolve

      31.0: missing requirement package; (package=javax.naming)

              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3531)

              at org.apache.felix.framework.Felix.startBundle(Felix.java:1804)

              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1233)

              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)

              at java.lang.Thread.run(Thread.java:722)

      ERROR: Bundle org.apache.karaf.features.core Error starting mvn:org.apache.karaf.features/org.apache.karaf.features.

      core/2.2.2-fuse-08-15 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.features.core

      : Unable to resolve 32.0: missing requirement package; (package=javax.management))

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.features.core : Unable to resolv

      e 32.0: missing requirement package; (package=javax.management)

              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3531)

              at org.apache.felix.framework.Felix.startBundle(Felix.java:1804)

              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1233)

              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)

              at java.lang.Thread.run(Thread.java:722)

      ERROR: Bundle org.apache.karaf.deployer.wrap Error starting mvn:org.apache.karaf.deployer/org.apache.karaf.deployer.

      wrap/2.2.2-fuse-08-15 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.deployer.wrap

      : Unable to resolve 33.0: missing requirement package; (&(package=org.apache.felix.fileinstall)(version>=3.3.

      0)(!(version>=4.0.0))) [caused by: Unable to resolve 7.0: missing requirement package; (&(package=org.osgi.framewor

      k)(version>=1.4.0)(!(version>=2.0.0)))])

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.deployer.wrap : Unable to resolv

      e 33.0: missing requirement package; (&(package=org.apache.felix.fileinstall)(version>=3.3.0)(!(version>=4.0.0)))

      [caused by: Unable to resolve 7.0: missing requirement package; (&(package=org.osgi.framework)(version>=1.4.0)(!(ve

      rsion>=2.0.0)))]

              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3531)

              at org.apache.felix.framework.Felix.startBundle(Felix.java:1804)

              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1233)

              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)

              at java.lang.Thread.run(Thread.java:722)

      ERROR: Bundle org.apache.karaf.deployer.features Error starting mvn:org.apache.karaf.deployer/org.apache.karaf.deplo

      yer.features/2.2.2-fuse-08-15 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.deplo

      yer.features : Unable to resolve 34.0: missing requirement package; (package=javax.xml.parsers))

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.deployer.features : Unable to re

      solve 34.0: missing requirement package; (package=javax.xml.parsers)

              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3531)

              at org.apache.felix.framework.Felix.startBundle(Felix.java:1804)

              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1233)

              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)

              at java.lang.Thread.run(Thread.java:722)

      ERROR: Bundle org.apache.karaf.shell.log Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.log/2.2.2-

      fuse-08-15 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.log : Unable t

      o resolve 35.0: missing requirement package; (&(package=org.apache.felix.gogo.commands)(version>=0.10.0)(!(version

      >=1.0.0))) [caused by: Unable to resolve 20.0: missing requirement package; (package=javax.security.auth)])

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.log : Unable to resolve 35

      .0: missing requirement package; (&(package=org.apache.felix.gogo.commands)(version>=0.10.0)(!(version>=1.0.0))) [

      caused by: Unable to resolve 20.0: missing requirement package; (package=javax.security.auth)]

              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3531)

              at org.apache.felix.framework.Felix.startBundle(Felix.java:1804)

              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1233)

              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)

              at java.lang.Thread.run(Thread.java:722)

      ERROR: Bundle org.apache.karaf.admin.management Error starting mvn:org.apache.karaf.admin/org.apache.karaf.admin.man

      agement/2.2.2-fuse-08-15 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.admin.mana

      gement : Unable to resolve 36.0: missing requirement package; (package=javax.management))

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.admin.management : Unable to res

      olve 36.0: missing requirement package; (package=javax.management)

              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3531)

              at org.apache.felix.framework.Felix.startBundle(Felix.java:1804)

              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1233)

              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)

              at java.lang.Thread.run(Thread.java:722)

      ERROR: Bundle org.apache.mina.core Error starting mvn:org.apache.mina/mina-core/2.0.1 (org.osgi.framework.BundleExce

      ption: Unresolved constraint in bundle org.apache.mina.core : Unable to resolve 37.0: missing requirement pack

      age; (package=javax.crypto))

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.mina.core : Unable to resolve 37.0: mi

      ssing requirement package; (package=javax.crypto)

              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3531)

              at org.apache.felix.framework.Felix.startBundle(Felix.java:1804)

              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1233)

              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)

              at java.lang.Thread.run(Thread.java:722)

      ERROR: Bundle org.apache.karaf.diagnostic.command Error starting mvn:org.apache.karaf.diagnostic/org.apache.karaf.di

      agnostic.command/2.2.2-fuse-08-15 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.d

      iagnostic.command : Unable to resolve 38.0: missing requirement package; (&(package=org.apache.felix.gogo.comm

      ands)(version>=0.10.0)(!(version>=1.0.0))) [caused by: Unable to resolve 20.0: missing requirement package; (packa

      ge=javax.security.auth)])

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.diagnostic.command : Unable to r

      esolve 38.0: missing requirement package; (&(package=org.apache.felix.gogo.commands)(version>=0.10.0)(!(version>=1

      .0.0))) [caused by: Unable to resolve 20.0: missing requirement package; (package=javax.security.auth)]

              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3531)

              at org.apache.felix.framework.Felix.startBundle(Felix.java:1804)

              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1233)

              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)

              at java.lang.Thread.run(Thread.java:722)

      ERROR: Bundle org.apache.karaf.jaas.command Error starting mvn:org.apache.karaf.jaas/org.apache.karaf.jaas.command/2

      .2.2-fuse-08-15 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.jaas.command :

      Unable to resolve 39.0: missing requirement package; (package=javax.management))

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.jaas.command : Unable to resolve

      39.0: missing requirement package; (package=javax.management)

              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3531)

              at org.apache.felix.framework.Felix.startBundle(Felix.java:1804)

              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1233)

              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)

              at java.lang.Thread.run(Thread.java:722)

      ERROR: Bundle org.apache.karaf.management Error starting mvn:org.apache.karaf/org.apache.karaf.management/2.2.2-fuse

      -08-15 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.management : Unable to r

      esolve 40.0: missing requirement package; (package=javax.management))

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.management : Unable to resolve 4

      0.0: missing requirement package; (package=javax.management)

              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3531)

              at org.apache.felix.framework.Felix.startBundle(Felix.java:1804)

              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1233)

              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)

              at java.lang.Thread.run(Thread.java:722)

      ERROR: Bundle org.apache.karaf.diagnostic.management Error starting mvn:org.apache.karaf.diagnostic/org.apache.karaf

      .diagnostic.management/2.2.2-fuse-08-15 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.k

      araf.diagnostic.management : Unable to resolve 41.0: missing requirement package; (package=javax.management))

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.diagnostic.management : Unable t

      o resolve 41.0: missing requirement package; (package=javax.management)

              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3531)

              at org.apache.felix.framework.Felix.startBundle(Felix.java:1804)

              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1233)

              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)

              at java.lang.Thread.run(Thread.java:722)

      ERROR: Bundle org.apache.karaf.features.obr Error starting mvn:org.apache.karaf.features/org.apache.karaf.features.o

      br/2.2.2-fuse-08-15 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.features.obr [4

      2]: Unable to resolve 42.0: missing requirement package; (&(package=org.apache.felix.bundlerepository)(version>=2.

      0.0)(!(version>=3.0.0))) [caused by: Unable to resolve 6.0: missing requirement package; (&(package=org.osgi.framew

      ork)(version>=1.3.0)(!(version>=2.0.0)))])

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.features.obr : Unable to resolve

      42.0: missing requirement package; (&(package=org.apache.felix.bundlerepository)(version>=2.0.0)(!(version>=3.0.0

      ))) [caused by: Unable to resolve 6.0: missing requirement package; (&(package=org.osgi.framework)(version>=1.3.0)(

      !(version>=2.0.0)))]

              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3531)

              at org.apache.felix.framework.Felix.startBundle(Felix.java:1804)

              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1233)

              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)

              at java.lang.Thread.run(Thread.java:722)