1 Reply Latest reply on Aug 21, 2014 8:00 AM by Wolf-Dieter Fink

    Deploy fails on jboss-as-server-7.1.1.Final with "Empty name segment is not allowed for env"

    Mary Boose Newbie

      Where can I find this empty name segement?

       

      server.log

      17:36:39,151 INFO  [org.jboss.as.connector.subsystems.datasources] (MSC service thread 1-2) JBAS010400: Bound data source [java:jboss/jdbc/bluestoredb1]

      17:36:39,152 INFO  [org.jboss.as.connector.subsystems.datasources] (MSC service thread 1-2) JBAS010400: Bound data source [java:jboss/jdbc/bluestoredb3]

      17:36:39,157 INFO  [org.jboss.as.connector.subsystems.datasources] (MSC service thread 1-1) JBAS010400: Bound data source [java:jboss/jdbc/bluestoredb2]

      ......

      17:42:16,809 INFO  [org.jboss.as.repository] (HttpManagementService-threads - 1) JBAS014900: Content added at location /usr/local/jboss-7.1.1/standalone/data/content/64/cac3a7ecd332d362526a6ac726620c91d897fb/content

       

      17:42:29,784 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015876: Starting deployment of "BlueStoreJBoss.war"

      17:42:30,396 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-1) MSC00001: Failed to start service jboss.deployment.unit."BlueStoreJBoss.war".INSTALL: org.jboss.msc.service.StartException in service jboss.deployment.unit."BlueStoreJBoss.war".INSTALL: Failed to process phase INSTALL of deployment "BlueStoreJBoss.war"

              at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:119) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]

              at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

              at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

              at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110) [rt.jar:1.6.0_22]

              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603) [rt.jar:1.6.0_22]

              at java.lang.Thread.run(Thread.java:679) [rt.jar:1.6.0_22]

      Caused by: java.lang.IllegalArgumentException: Empty name segment is not allowed for env

              at org.jboss.msc.service.ServiceName.of(ServiceName.java:85) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

              at org.jboss.msc.service.ServiceName.append(ServiceName.java:112) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

              at org.jboss.as.naming.deployment.ContextNames.buildServiceName(ContextNames.java:178)

              at org.jboss.as.naming.deployment.ContextNames$BindInfo.<init>(ContextNames.java:190)

              at org.jboss.as.naming.deployment.ContextNames$BindInfo.<init>(ContextNames.java:181)

              at org.jboss.as.naming.deployment.ContextNames.bindInfoFor(ContextNames.java:136)

              at org.jboss.as.naming.deployment.ContextNames.bindInfoForEnvEntry(ContextNames.java:165)

              at org.jboss.as.ee.component.deployers.ModuleJndiBindingProcessor.deploy(ModuleJndiBindingProcessor.java:115)

              at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:113) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]

              ... 5 more

       

       

      17:42:30,480 INFO  [org.jboss.as.server] (HttpManagementService-threads - 1) JBAS015870: Deploy of deployment "BlueStoreJBoss.war" was rolled back with failure message {"JBAS014671: Failed services" => {"jboss.deployment.unit.\"BlueStoreJBoss.war\".INSTALL" => "org.jboss.msc.service.StartException in service jboss.deployment.unit.\"BlueStoreJBoss.war\".INSTALL: Failed to process phase INSTALL of deployment \"BlueStoreJBoss.war\""}}

      17:42:30,551 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015877: Stopped deployment BlueStoreJBoss.war in 70ms

      17:42:30,573 INFO  [org.jboss.as.controller] (HttpManagementService-threads - 1) JBAS014774: Service status report

      JBAS014777:   Services which failed to start:      service jboss.deployment.unit."BlueStoreJBoss.war".INSTALL: org.jboss.msc.service.StartException in service jboss.deployment.unit."BlueStoreJBoss.war".INSTALL: Failed to process phase INSTALL of deployment "BlueStoreJBoss.war"

       

      snippet from web.xml

      <resource-ref id="bluestoredb1">
      <res-ref-name>jdbc/bluestoredb1</res-ref-name>
      <res-type>javax.sql.DataSource</res-type>
      <res-auth>Container</res-auth>
      </resource-ref>
      <resource-ref id="bluestoredb2">
      <res-ref-name>jdbc/bluestoredb2</res-ref-name>
      <res-type>javax.sql.DataSource</res-type>
      <res-auth>Container</res-auth>
      </resource-ref>
      <resource-ref id="bluestoredb3">
      <res-ref-name>jdbc/bluestoredb3</res-ref-name>
      <res-type>javax.sql.DataSource</res-type>
      <res-auth>Container</res-auth>
      </resource-ref>

      </web-app>

       

       

       

      jboss-web.xml

      <?xml version="1.0" encoding="UTF-8"?>

      <jboss-web>

        <resource-ref id="bluestoredb1">

        <res-ref-name>/jdbc/bluestoredb1</res-ref-name>

        <res-type>javax.sql.DataSource</res-type>

        <res-auth>Container</res-auth>

        <jndi-name>java:jboss/jdbc/bluestoredb1</jndi-name>

        </resource-ref>

        <resource-ref id="bluestoredb2">

        <res-ref-name>/jdbc/bluestoredb2</res-ref-name>

        <res-type>javax.sql.DataSource</res-type>

        <res-auth>Container</res-auth>

        <jndi-name>java:jboss/jdbc/bluestoredb2</jndi-name>

        </resource-ref>

        <resource-ref id="bluestoredb3">

        <res-ref-name>/jdbc/bluestoredb3</res-ref-name>

        <res-type>javax.sql.DataSource</res-type>

        <res-auth>Container</res-auth>

        <jndi-name>java:jboss/jdbc/bluestoredb3</jndi-name>

        </resource-ref>

      </jboss-web>

       

      snippet from standalone.xml

                    <datasource jta="false" jndi-name="java:jboss/jdbc/bluestoredb1" pool-name="bluestoredb1" enabled="true" use-ccm="false">

                          <connection-url>jdbc:oracle:thin:@xxxxxx:1521:xxxxx</connection-url>

                          <driver-class>oracle.jdbc.OracleDriver</driver-class>

                          <driver>ojdbc6.jar</driver>

                          <security>

                              <user-name>xxxxx</user-name>

                              <password>xxxxxword>

                          </security>

                          <validation>

                              <validate-on-match>false</validate-on-match>

                              <background-validation>false</background-validation>

                          </validation>

                          <statement>

                              <share-prepared-statements>false</share-prepared-statements>

                          </statement>

                      </datasource>