3 Replies Latest reply on Aug 26, 2014 1:58 PM by Claus Ibsen

    JBoss Fuse 6.1 ActiveMQ error: User name [null] or password is invalid

    Gerard COLLIN Newbie

      Hi all,

      I'm using JBoss Fuse 6.1, with a simple component that just send a message to the main broker:

      <bean id="SimulatorProcessor" class="com.agcs.esb.poc.UpdatedEntitySimulator" />

          <camelContext xmlns="http://camel.apache.org/schema/blueprint">

         <route id="simulateUpdate">
         <from uri="timer:simulator?period=5000" />
                          <log message="Generating new update Message" />
                          <process ref="SimulatorProcessor" />
                          <log message="Generated new update Message" />
                          <to uri="activemq:US.out" />
         </route>

       

          </camelContext>

       

      I have deployed it in the core instance of JBoss Fuse.

      However, after many problems (all fixed by deleting the content of data/cache directory), I know get this error

      org.apache.activemq.activemq-osgi - 5.9.0.redhat-610379 | Failed to add Connection ID:O12L20995-55581-1408986076466-1:1

      java.lang.SecurityException: User name [null] or password is invalid.

      ...

       

      I've seen quite some people having the same mistakes for some time now, but how to fix that? Where should I put user / password? Which value? I didn't see anything like user/password in the activemq config files....

      BTW, the same route works fine with apache servicemix 5.11

       

      Regards,

      Gcc