1 Reply Latest reply on Sep 1, 2014 10:43 AM by Alex Punnen

    JBOSS AS 7.1.1 domain mode (clustred), MDB deployment failing

    Alex Punnen Newbie

      HI,

      I have a simple MDB that works properly in standalone mode; However when I have a master slave configuration following JBOSS clustering guideline (and starting both master and slave in the domain mode), I am able to deploy and connect to a clustered hornetq and also send messages to it. But I am unable to deploy a simple mdb to consume messages from it.

       

      The error that is comming is

       

       

      09:38:11,160 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-4) JBAS015876: Starting deployment of "MroExecutorEar.ear"

      09:38:11,266 WARN  [org.jboss.as.server.deployment] (MSC service thread 1-2) Class Path entry lib/jgraph.jar in "/content/MroExecutorEar.ear/lib/jgrapht-jdk1.5-0.7.3.jar"  does not point to a valid jar for a Class-Path reference.

      09:38:11,268 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015876: Starting deployment of "MroExecutor.jar"

      09:38:11,589 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-2) JBAS015877: Stopped deployment MroExecutor.jar in 49ms

      09:38:11,597 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-4) JBAS015877: Stopped deployment MroExecutorEar.ear in 57ms

      09:38:11,601 INFO  [org.jboss.as.server] (host-controller-connection-threads - 1) JBAS015863: Replacement of deployment "MroExecutorEar.ear" by deployment "MroExecutorEar.ear" was rolled back with failure message {"JBAS014771: Services with missing/unavailable dependencies" => ["jboss.deployment.subunit.\"MroExecutorEar.ear\".\"MroExecutor.jar\".component.MroExecutorMDB.CREATEjboss.ra.socketMissing[jboss.deployment.subunit.\"MroExecutorEar.ear\".\"MroExecutor.jar\".component.MroExecutorMDB.CREATEjboss.ra.socket]"]

       

      Note I tried out most of the threads there  regarding this, the following below being the last I tried; still no success with this and not able to understand the cause too.

      MessageDriver erro

       

      Am I missing some dependencies in my pom (attached), or in my configuration (domain.xm) or in the code (MroExecutorMDB.java)

       

      All three files attached.

        • 1. Re: JBOSS AS 7.1.1 domain mode (clustred), MDB deployment failing
          Alex Punnen Newbie

          Got it working; Added full-ha-sockets instead of ha-sockets as described in domain.xml Jboss threads elsewhere

           

          <server-group name="other-server-group" profile="full-ha">

                      <jvm name="default">

                          <heap size="64m" max-size="512m"/>

                      </jvm>

                      <socket-binding-group ref="full-ha-sockets"/>

                      <deployments>

                          <deployment name="MroControllerEar.ear" runtime-name="MroControllerEar.ear"/>

                      </deployments>

                  </server-group>