1 Reply Latest reply on Sep 3, 2014 1:57 AM by jaikiran pai

    What is the correct way to provide jvm args?

    Ricki Lambert Newbie

      I am trying to provide jboss command line arguments to configure jvm variables. My standalone.sh looks as follows;

      ## -*- shell-script -*- ######################################################

      ##                                                                          ##

      ##  JBoss Bootstrap Script Configuration                                    ##

      ##                                                                          ##

      ##############################################################################

       

      #

      # This file is optional; it may be removed if not needed.

      #

       

      #

      # Specify the maximum file descriptor limit, use "max" or "maximum" to use

      # the default, as queried by the system.

      #

      # Defaults to "maximum"

      #

      #MAX_FD="maximum"

       

      #

      # Specify the profiler configuration file to load.

      #

      # Default is to not load profiler configuration file.

      #

      #PROFILER=""

       

      #

      # Specify the location of the Java home directory.  If set then $JAVA will

      # be defined to $JAVA_HOME/bin/java, else $JAVA will be "java".

      #

      #JAVA_HOME="/opt/java/jdk"

       

      #

      # Specify the exact Java VM executable to use.

      #

      #JAVA=""

       

      if [ "x$JBOSS_MODULES_SYSTEM_PKGS" = "x" ]; then

         JBOSS_MODULES_SYSTEM_PKGS="org.jboss.byteman"

      fi

       

      # Uncomment the following line to prevent manipulation of JVM options

      # by shell scripts.

      #

      #PRESERVE_JAVA_OPTS=true

       

      #

      # Specify options to pass to the Java VM.

      #

      if [ "x$JAVA_OPTS" = "x" ]; then

         JAVA_OPTS="-Xms1303m -Xmx1303m -XX:MaxPermSize=256m -Djava.net.preferIPv4Stack=true"

         JAVA_OPTS="$JAVA_OPTS -Duser.timezone=GMT"

         JAVA_OPTS="$JAVA_OPTS -Djboss.modules.system.pkgs=$JBOSS_MODULES_SYSTEM_PKGS -Djava.awt.headless=true"

         JAVA_OPTS="$JAVA_OPTS -Djboss.modules.policy-permissions=true"

         JAVA_OPTS="$JAVA_OPTS -Djboss.bind.address.management=0.0.0.0"

         JAVA_OPTS="$JAVA_OPTS -DEnvironment=DEV"

      else

         echo "JAVA_OPTS already set in environment; overriding default settings with values: $JAVA_OPTS"

      fi

       

      # Sample JPDA settings for remote socket debugging

      #JAVA_OPTS="$JAVA_OPTS -agentlib:jdwp=transport=dt_socket,address=8787,server=y,suspend=n"

       

      # Sample JPDA settings for shared memory debugging

      #JAVA_OPTS="$JAVA_OPTS -agentlib:jdwp=transport=dt_shmem,server=y,suspend=n,address=jboss"

       

      # Uncomment to not use JBoss Modules lockless mode

      #JAVA_OPTS="$JAVA_OPTS -Djboss.modules.lockless=false"

       

      # Uncomment to gather JBoss Modules metrics

      #JAVA_OPTS="$JAVA_OPTS -Djboss.modules.metrics=true"

      If you notice, I am trying to provide my own value named Environment which i wish to set development, uat or production.

      In my java application I am trying to receive this value as follows;

      String environment = System.getProperty("Environment"); 

      This always seems to be null and I am not sure why.

      Am I configuring this correctly?

      Thanks