0 Replies Latest reply on Sep 1, 2014 8:02 PM by Renato Resende Ribeiro de Oliveira

    Weld 2 and CDI 1.1 on EAP

    Renato Resende Ribeiro de Oliveira Newbie

      Hello,

      I need to run an application developed with Weld 2.1 and CDI 1.1 in a JBoss EAP environment.

      If i try to deploy this application in EAP 6.2, it loads the Weld 1.1 and some exception are thrown (as expected).

       

      My question is, what is the better way to me?

      1. There is any way that i can prevent the loading of the included Weld 1.1 module and load the Weld from my lib directory JARs?

      2. There is a simple way to upgrade the Weld module in EAP to the version 2 of Weld?

      3. If there is no solution, which is the estimated date to EAP supports Weld 2, CDI 1.1 and JavaEE 7?

       

      I listed the options in order of my preference.

       

      Att.