2 Replies Latest reply on Sep 15, 2014 1:37 PM by Philip Cootey

    Camel Endpoint Discovery : fabric:ClusterID not found even after installing feature

    Philip Cootey Newbie

      I have a glassfish endpoint with a rest interface.  We want to access this through the ESB.  It looks like I can use fabric:ClusterID:http://myrestendpoint/myreststuff so that I can route to my service through the ESB.  I believe this is Camel endpoint discovery. https://access.redhat.com/documentation/en-US/Red_Hat_JBoss_Fuse/6.1/html-single/Fabric_Guide/index.html.  I can't get the command.

       

      First Question: Is Camel Endpoint Discovery the right way to go?

       

      Steps I took:

      1. When I run the command from my console I get "Command not found: fabric:ClusterID:http://myrestendpoint". 
      2. Further investigation in documentation indicates I need to install fabric-camel https://access.redhat.com/documentation/en-US/Red_Hat_JBoss_Fuse/6.1/html/Apache_Camel_Component_Reference/files/Fabric.html
      3. I went ahead and installed the feature, that didn't work, "Error executing command: The container is managed by fabric, please use fabric:profile-edit --features fabric-camel/0.0.0 target-profile instead. See fabric:profile  --help for more information." 
      4. Then I tried the installing on the profile associated with root. jboss-fuse-full.  That installed the feature but still no command.
      
      JBossFuse:karaf@root> features:list | grep fabric-camel
      [uninstalled] [1.0.0.redhat-379       ] fabric-camel-cxf                        fabric-camel-cxf-1.0.0.redhat-379
      [installed  ] [1.0.0.redhat-379       ] fabric-camel                            fabric-1.0.0.redhat-379
      [uninstalled] [1.0.0.redhat-379       ] fabric-camel-autotest                   fabric-1.0.0.redhat-379
      [uninstalled] [6.1.0.redhat-379       ] mq-fabric-camel                         fabric-1.0.0.redhat-379
      
      

       

      I have to be missing some prerequisite.  The container: root is associated with the JBoss/Fuse profile 'full' and yet no ClusterID command.

       

      My prompt looks like

      JBossFuse:karaf@root>

       

      I saw that I could use the Console Manager to add the profile, So here it is.  I am still unable to user the command.  I thought the container list could help trouble shoot/shed light on what I missed.

       

      JBossFuse:karaf@root> fabric:container-list

      [id]                           [version] [connected] [profiles]                                         [provision status]

      EAPrototype-2                  1.0       true        fabric, fabric-ensemble-0001-2                     success

      EAPrototype-3                  1.0       true        fabric, fabric-ensemble-0001-3                     success

      FabricContainer-1              1.0       true        fabric, feature-camel                              success

      FabricContainer-2              1.0       false       fabric                                             success

      root*                          1.0       true        fabric, fabric-ensemble-0000-1, jboss-fuse-full, fabric-ensemble-0001-1, feature-camel success

       

      -

       

      Something I noticed, no camel icon for root in the Management Console.