0 Replies Latest reply on Sep 12, 2014 1:50 AM by santhosh kumar

    Application deployment error while migrating from weblogic to jboss 6.2 EAP Server

    santhosh kumar Newbie

      Here the below changes which I done to migrate My application to support “JBOSS 6.2 EAP Server”

       

      1: Using Eclipse IDE, Generated “jboss.xml” to support ejb-jar.xml. So “jboss.xml” is the replacement for “weblogic-ejb-jar.xml”.

      Hope this is how ejb JNDI are bounded in jboss 6.2EAP  as below.

       

      jndi.jpg

       

       

      2: Created Datasource for “Oracle and MSSql server” in JBOSS Subsystem.

       

      Both Data source Connectivity are tested using “jboss-cli” command.

       

      Now while deploying the EAR file into the server. EAR Getting deployed into the server. Deployed status is also true in console.

      deployment.jpg

      Issue 1)

       

      Am seeing "null" value while deploying my “ApplicationEAR.ear” file, It is not thrown an error just INFO. If this is problem. Please advise.

      Only I could see two modules inside EAR (EJB jar (BusinessTier) and PresentationTier) . It is not reading other dependency modules but it is available inside EAR Root. Not under “WEB-INF/lib”.

       

       

      23:26:07,014 INFO [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015876: Starting deployment of "null" (runtime-name: "BusinessTier.jar")

      23:26:07,014 INFO [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015876: Starting deployment of "null" (runtime-name: "PresentationTier.war")

       

      Issue 2)

       

       

      ClassNot Found Exception, Though Commons-Configuration.jar is available in both “WEB-INF/lib” and also set in class path reference.

       

       

      00:19:22,667 ERROR [org.apache.catalina.core.ContainerBase.[jboss.web].[default-host].[/vos]] (ServerService Thread Pool -- 70) JBWEB000289: Servlet action threw load() exception: java.lang.ClassNotFoundException: org.apache.commons.configuration.ConfigurationException from [Module "deployment.ApplicationEAR.ear:main" from Service Module Loader].

       

       

      Are we need to change any subsystem? , Other than Datasource subsystem! Please advise and do the needful.

      Am attaching the full log file for your reference.