3 Replies Latest reply on Sep 19, 2014 6:17 AM by Venkateswaran Selvaraj

    horo-app  fuse 6.1 version mis match

    Venkateswaran Selvaraj Newbie

      i am trying to deploy horo-app application in JBOSS Fuse 6.1 , when i install i am getting the below error.

       

      What is the reason and as per the redhat documents it has been mentioned as fuse 6.1 supports spring 3.2.x.RELEASE and i had even tried changing to 3.1.X.RELEASE , i am getting the same exception.

       

      could any one help me in understanding the issue?

       

       

      Error executing command: Could not start bundle mvn:com.fusesource.examples/horo-db/1.0-SNAPSHOT in feature(s) horo-db-1.0-SNAPSHOT: Unresolved constraint in bundle horo-db [510]:

      Unable to resolve 510.0: missing requirement [510.0] osgi.wiring.package; (&(osgi.wiring.package=org.mybatis.spring)(version>=1.1.0)(!(version>=2.0.0))) [caused by: Unable to res

      olve 512.0: missing requirement [512.0] osgi.wiring.package; (osgi.wiring.package=org.springframework.jdbc.datasource) [caused by: Unable to resolve 513.0: missing requirement [51

      3.0] osgi.wiring.package; (&(osgi.wiring.package=org.springframework.beans)(version>=3.2.4.RELEASE)(version<=3.2.4.RELEASE))]]

        • 1. Re: horo-app  fuse 6.1 version mis match
          Claus Ibsen Master

          Do you have mybatis-spring installed, eg if you do a osgi:list, do you see this bundle installed?

          • 2. Re: horo-app  fuse 6.1 version mis match
            Venkateswaran Selvaraj Newbie

            Thanks for the response. No it is not available , i thought the step three in the instruction list will do that for me .

             

            3) Add this projects features.xml config to Fuse from the Console

               (makes it easier to install bundles with all required dependencies)

              JBossFuse:karaf@root> features:addUrl mvn:com.fusesource.examples/horo-features/1.0-SNAPSHOT/xml/features

             

            So do i have to manullay install all the reqiured jars like ?

             

            install -s mvn:org.mybatis/mybatis-spring/1.1.1

             

             

            • 3. Re: horo-app  fuse 6.1 version mis match
              Venkateswaran Selvaraj Newbie

              I tried to install the below bundles manually but am getting the exceptions for the Spring jdbc and mybatis-spring it couldn't resolve the org.springframework.beans)(version>=3.2.4.RELEASE)(version<=3.2.4.RELEASE))] .Could you please provide inputs on this .

               

              Also do i have to manually install the spring core context beans etc because i coudln't see any of those bundles installed by default

               

              JBossFuse:admin@root> list | grep spring

              [ 149] [Active     ] [            ] [       ] [   50] camel-spring (2.12.0.redhat-610379)

              [ 230] [Active     ] [            ] [       ] [   50] camel-spring-javaconfig (2.12.0.redhat-610379)

              JBossFuse:admin@root>

               

              install -s mvn:postgresql/postgresql/9.1-901.jdbc4  -success

              install -s mvn:c3p0/c3p0/0.9.1.2 -success

              install -s mvn:org.mybatis/mybatis/3.1.1 -success

              install -s mvn:org.mybatis/mybatis-spring/1.1.1

              Error executing command: Error installing bundles:

                      Unable to start bundle mvn:org.mybatis/mybatis-spring/1.1.1: Unresolved constraint in bundle org.mybatis.mybatis-spring [543]: Unable to resolve 543.0: missing requirement

              [543.0] osgi.wiring.package; (osgi.wiring.package=org.springframework.jdbc.datasource) [caused by: Unable to resolve 544.0: missing requirement [544.0] osgi.wiring.package; (&(os

              gi.wiring.package=org.springframework.beans)(version>=3.2.4.RELEASE)(version<=3.2.4.RELEASE))]

               

              install -s mvn:org.springframework/org.springframework.jdbc/3.2.4.RELEASE

              Error executing command: Error installing bundles:

                      Unable to start bundle mvn:org.springframework/org.springframework.jdbc/3.2.4.RELEASE: Unresolved constraint in bundle org.springframework.jdbc [544]: Unable to resolve 54

              4.0: missing requirement [544.0] osgi.wiring.package; (&(osgi.wiring.package=org.springframework.beans)(version>=3.2.4.RELEASE)(version<=3.2.4.RELEASE))

               

              install -s mvn:org.springframework.batch/spring-batch-infrastructure/2.1.9.RELEASE -success

              install -s mvn:org.apache.camel/camel-mybatis/2.12.0.redhat-610379 -success

               

               

              osgi:list

               

              [ 290] [Active     ] [            ] [       ] [   60] wrap_mvn_org.jboss_jandex_1.1.0.Final (0)

              [ 291] [Active     ] [            ] [       ] [   60] JBoss Logging 3 (3.1.4.GA)

              [ 297] [Active     ] [            ] [       ] [   60] ojdbc (11.2.0.0)

              [ 298] [Active     ] [            ] [       ] [   60] commons-dbcp (1.2.2)

              [ 540] [Active     ] [            ] [       ] [   60] mvn:postgresql/postgresql/9.1-901.jdbc4

              [ 541] [Active     ] [            ] [       ] [   60] mvn:c3p0/c3p0/0.9.1.2

              [ 542] [Active     ] [            ] [       ] [   60] MyBatis (3.1.1)

              [ 543] [Installed  ] [            ] [       ] [   60] MyBatis-Spring (1.1.1)

              [ 544] [Installed  ] [            ] [       ] [   60] Spring JDBC (3.2.4.RELEASE)

              [ 545] [Active     ] [            ] [       ] [   60] Spring Batch Infrastructure (2.1.9.RELEASE)

              [ 546] [Active     ] [            ] [       ] [   60] camel-mybatis (2.12.0.redhat-610379)

              [ 547] [Active     ] [            ] [       ] [   60] Horoscope aggregator app :: horo-model (1.0.0.SNAPSHOT)

              [ 548] [Active     ] [            ] [       ] [   60] Joda-Time (2.1)