3 Replies Latest reply on Sep 22, 2014 1:11 AM by Horia Chiorean

    Failing to load jgroups config file

    Ross Woolf Newbie

      Modeshape fails to load the jgroups configuration file.

      I have a web application in which I have embedded Modeshape.  I am using Modeshape 3.8.0.

      I have the following configuration in my Modeshape configuration file.

        "clustering" : {

          "clusterName" : "my-repo-cluster",

          "channelConfiguration" : "/home/ross/conf/jgroups-config.xml"

        }

      I have also tried "file://home/ross/conf/jgroups-config.xml" and "jgroups-config.xml" and with the latter I have put the config file in my WEB-INF folder.

       

      Regardless of what I do I always get the following error:

      java.io.IOException: JGRP000004: parsing failure; the XML document is not correct: InputStream cannot be null

        at org.jgroups.conf.XmlConfigurator.parse(XmlConfigurator.java:173) ~[jgroups-3.2.13.Final.jar:3.2.13.Final]

      ...

      javax.jcr.RepositoryException: Error while starting 'longterm' repository: Cannot create a valid JGroups channel using the configuration: /home/ross/conf/jgroups-config.xml

        at org.modeshape.jcr.JcrRepository.login(JcrRepository.java:650) ~[modeshape-jcr-3.8.0.Final.jar:3.8.0.Final]

       

      For the jgroups-config.xml file I simply copied the configuration from:

      ModeShape in Java applications - ModeShape 3 - Project Documentation Editor

       

      If I change my configuration file to name a non existent file "dummy.xml" then I get the exact same error, so for whatever reason, even though the jgroups-config.xml file exists in the indicated location, it is unable to find or read it.  Rights on the file are such that it is readable by all.

      I even moved this over to a windows machine and the exact problem exists there. 

       

      Is my configuration wrong?  Is there some other way to indicate the exact path in the file system to the indicated file?  I have played with this for almost a day with no success in getting the jgroups-config.xml file to be read.  Just by way of info, I also have my modeshape and infinispan configuration files in this same directory and the app has no problem reading these files from there.

       

      Any help on this would be appreciated.