0 Replies Latest reply on Sep 22, 2014 10:55 AM by Jitendra sharma

    Not able to access product UI through ipv6 , but same Jboss 4.2.2 server is accessible with ipv4 address

    Jitendra sharma Newbie

                    I am doing ipv6 testing on our product. I am able to ping and ssh servers each other with ipv6 ip address. But when i am trying able to access product UI through Mozilla , it does not come up.                  But same server is accessible with ipv4

       

      When I ran below  command we got -Djava.net.preferIPv4Stack=true .Because when we hit ipv6 url it goes to app server there may be chance server block this request because ipv6 is not enabled for app server.

      vm-adip-16:~ # ps -ef | grep jboss

      root 6555  4626  0 04:59 pts/2    00:00:00 grep jboss

      oracle 27042     1  0 Sep02 ? 00:00:00 /bin/sh /home/oracle/jboss/bin/run.sh -c default -b 0.0.0.0

      oracle 27065 27042  2 Sep02 ?        01:12:17 /etc/alternatives/java_sdk_1.6.0/bin/java -Dprogram.name=run.sh -Xmx2048m -XX:MaxPermSize=512M -Djava.awt.headless=true -XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath=/home/oracle

      -Djava.net.preferIPv4Stack=true -Djava.endorsed.dirs=/home/oracle/jboss/lib/endorsed -classpath /home/oracle/jboss/bin/run.jar:/etc/alternatives/java_sdk_1.6.0/lib/tools.jar org.jboss.Main -c default -b 0.0.0.0


      i am trying to access UI in same network. i have logged in on vms through x-window and opened firefox and tried to access UI.But it does not work. even I have enabled firefox ipv6 setting as well.


      i am suspecting problem with app server site (jboss 4.2.2) , because it is not picking ipv6 address while hitting url. it takes ipv4 request.


      Do any have idea , why i am not able to access UI , when server is communicate and  ping each other.


      Thanks,

      Jitendra sharma