0 Replies Latest reply on Sep 23, 2014 10:03 AM by Swapnesh Karpe

    Migrating from JBoss EAP4.3 to JBoss EAP5.1.2

    Swapnesh Karpe Newbie



      Our application is built using myfaces 1.1.5, tomahawk 1.1.11 and deployed on JBoss EAP4.3.


      Now we are planning to migrate from 4.3 to 5.1.2. Initially i was facing some class loading issues (ClassCastException for xercesImpl), which I have resolved using jboss-classloading.xml.

      After resolving the above issue I am stuck with one weired issue - seems to be library issue but can't figure it out -

      UnsupportedOperationException - javax.faces.context.FacesContext.getELContext(FacesContext.java:154)


      Any help is appreciated


      *Just for information, the WAR is bundled in EAR andfinally EAR deploys on server.


      Thanks & Regards,