0 Replies Latest reply on Sep 29, 2014 3:44 PM by Al Koch

    Can't Launch JBoss 7.1.1 on Amazon AWS Windows Server2008R2 for Remote Access

    Al Koch Newbie

      Hello,

       

      I have an AWS (T2-small) Instance that is running Windows Server2008R2.  I have installed JBoss 7.1.1 (from jboss-as-7.1.1.Final.zip) and am able to launch it with "standalone.bat".  In this case I am able to access the server with a local browser @ http://localhost:8080 and http://localhost:9990.

       

      However, if I try to launch the server for remote access with "standalone.bat -b=PublicIPAddressOfTheAWSInstance" an attempt to reach to reach the server from a remote system using http://PublicIPAddressOfTheAWSInstance:8080 results in a "Timeout" and we don't connect.  Further, using a local browser:

      http://localhost:8080 still connects

      http://PublicIPAddressOfTheAWSInstance:8080 does not connect

      http://localhost:9990 no longer connects

      http://PublicIPAddressOfTheAWSInstance:9990 does not connect

       

      What may be an important hint is that I see the following error in the console log:

      ...

      11:48:54,459 INFO  [org.jboss.as.mail.extension] (MSC service thread 1-1) JBAS015400: Bound mail session [java:jboss/mail/Default]

      11:48:54,475 INFO  [org.jboss.as.server.deployment.scanner] (MSC service thread1-1) JBAS015012: Started FileSystemDeploymentService for directory C:\jboss-as-7

      .1.1.Final\standalone\deployments11:49:00,403 INFO  [org.jboss.as.controller] (Controller Boot Thread) JBAS014774

      : Service status reportJBAS014777:   Services which failed to start:      service jboss.network.public: org.jboss.msc.service.StartException in service jboss.network.public: JBAS015810: failed to resolve interface public

       

      11:49:00,419 INFO  [org.jboss.as] (Controller Boot Thread) JBAS015954: Admin console is not enabled

      11:49:00,419 ERROR [org.jboss.as] (Controller Boot Thread) JBAS015875: JBoss AS7.1.1.Final "Brontes" started (with errors) in 9142ms - Started 119 of 214 services (44 services failed or missing dependencies, 49 services are passive or on-demand)

       

      >>> Note the error: JBAS015810: failed to resolve interface public.

       

      Additional info: The AWS Instance is deployed in the default VPC and an AWS Security Group is defined to permit access to PublicIPAddressOfTheAWSInstance from all IP addresses using TCP on 8080.  Also, the Windows Firewall is disabled.

       

      I am guessing that "interface public" failing to resolve is related to why I can't get remote access.

       

      Note that if I launch with "standalone.bat -b=0.0.0.0" EVERYTHING WORKS!  There is no error in the log and remote access is available.  However, using 0.0.0.0 is not advisable for production.

       

      Can anyone help me understand why this is failing if I specify the AWS Public address?

       

      Thank you.