6 Replies Latest reply on Feb 13, 2015 10:11 AM by Tomaz Cerar

    EJB2 CMP WildFly 8.1.0

    tibu Newbie

      Hello,

      we would like to migrate to WildFly, but we have some code that contains entity beans..

      Is it possible to deploy a submodule, maybe from AS7, to bring back CMP support into WildFly 8.1.0?

       

      Thanks,

       

      Mathis

        • 1. Re: EJB2 CMP WildFly 8.1.0
          Philippe Marschall Expert

          AFAIK WildFly does not support CMP because it's optional in JavaEE 7.

          • 2. Re: EJB2 CMP WildFly 8.1.0
            Tomaz Cerar Master

            You could probably take CMP modules from 7.2 and manually install the thing.

            It could work but i would not recommend it.

            • 3. Re: EJB2 CMP WildFly 8.1.0
              tibu Newbie

              Hi,

               

              thank you very much for your answer.

              Could you please give me a little explanation, why you would not recommend it?

              I have not found it yet, but is the EJB2 CMP not just another module, that should be easy to plug in?

              Please tell me what the differences between this and some random third party module are. I hope I do not have a terrible misconception of the whole modularity

               

              Thanks,

              Mathis

              • 4. Re: EJB2 CMP WildFly 8.1.0
                Wolf-Dieter Fink Master

                The CMP module might be tight coupled to other modules. Since EJB2 will become out of date it is not a high priority to optimize it since AS7. As AS7 is a redisign and lot of the server is re-written there is not all functionality moved from former releases to AS7.

                Since we move to EE7 the EJB2 Entity stuff become 'optional' and it is removed from Wildfly nobody will take care of the compatibility of internal interfaces and it might happen that the CMP module will not work any longer for each change as it will not maintained if there are changes to needed services.

                 

                So I recommend to stay with the current server version for EJB2 and migrate to EJB3/JPA together with the upgrade to WF8+.

                But this is a decision which you need to do for your application depend on the lifecycle of it.

                • 5. Re: EJB2 CMP WildFly 8.1.0
                  Philippe Marschall Expert

                  My understanding is the following things are optional in EE 7:

                  • EJB 2.1 and earlier Entity Bean Component Contract for Container-Managed Persistence
                  • EJB 2.1 and earlier Entity Bean Component Contract for Bean-Managed Persistence
                  • Client View of an EJB 2.1 and earlier Entity Bean
                  • EJB QL: Query Language for Container-Managed Persistence Query Methods

                  EJB2 itself is not optional, "only" entity beans.

                  • 6. Re: EJB2 CMP WildFly 8.1.0
                    Tomaz Cerar Master

                    Philippe Marschall wrote:

                     

                    My understanding is the following things are optional in EE 7:

                    • EJB 2.1 and earlier Entity Bean Component Contract for Container-Managed Persistence
                    • EJB 2.1 and earlier Entity Bean Component Contract for Bean-Managed Persistence
                    • Client View of an EJB 2.1 and earlier Entity Bean
                    • EJB QL: Query Language for Container-Managed Persistence Query Methods

                    EJB2 itself is not optional, "only" entity beans.

                    yes, only CMP is optional and only CMP support was removed from WildFly.

                    you can still you EJB2 sessions beans for example.