1 Reply Latest reply on Oct 7, 2014 4:08 PM by Rudi Fregent

    Installing a postgresql JDBC Driver with the Management Console on EAP 6.3

    Rudi Fregent Newbie

      On installing a postgresql JDBC Driver with the Management Console on EAP 6.3, I get the following error :

      "Deploying non-JDBC-compliant driver class org.postgresql.Driver (version 9.2)".

      I tried two jdbc connectors : postgresql-9.2-1004.jdbc4.jar and postgresql-9.2-1004.jdbc41.jar.

      The java.sql.Driver is like this :

      <<<

      $ cat META-INF/services/java.sql.Driver

      org.postgresql.Driver

      >>>

      And yet, the EAP 6.3 release note show that postgresql 9.2 is supported.

      Installing this postgres JDBC Driver as a Core Module also failed.

      Is there a solution or a workaround for this problem ?