2 Replies Latest reply on Oct 31, 2014 3:30 PM by Girish M

    Unable to engage rampart on JBoss EAP 6.1

    Girish M Newbie

      I have a web service client consuming a remote service using Axis2. The same axis2 client worked fine on JBoss 4.2.3 wherein the MAR files rampart-1.6.2.mar & addressing-1.6.2.mar were in webapp/WEB-INF/lib/ folder. But when the same is being deployed on to JBoss EAP 6.1, I keep getting "Unable to engage rampart" error. Anyone facing similar issue?

       

      Unable to engage module : rampart: org.apache.axis2.AxisFault: Unable to engage module : rampart

              at org.apache.axis2.client.ServiceClient.engageModule(ServiceClient.java:363) [axis2-1.6.2.jar:]

        • 1. Re: Unable to engage rampart on JBoss EAP 6.1
          Kedar Gaekwad Newbie

          I am facing similar issue with addressing.mar while consuming a service using Axis2.

          In my case the axis2 file was in a jar added as a dependency in ear / lib.

          The workaround that worked for me was to place this mar file outside ear / war and then provide the repo url while initializing the ConfigurationContextFactory.

          I placed the mar file under {jboss.server.config.dir}/modules. Also, added the modules.list file (which contains just the name of the mar file / files).

          Example

          ConfigurationContextFactory .createConfigurationContextFromURIs(<path to axis2ConfigFileURL>, file:///${jboss.server.config.dir} );

           

          In case, the axis2.xml file is available directly inside WEB-INF, we can use the following code and create the modules directory under WEB-INF. Don't forget to add the modules.list file (as mentioned below).

          File axis2RepositorURLFile = new File("vfs:///deployment/<ear or war> / WEB-INF");  (or try vfs:///content/ <ear or war> / WEB-INF

          ConfigurationContextFactory.createConfigurationContextFromURIs(null,  axis2RepositorURLFile.toURI().toURL());

           

          But its still a work around. Please let know, in case you were to resolve it in a clean way.

          • 2. Re: Unable to engage rampart on JBoss EAP 6.1
            Girish M Newbie

            I gave the path to MAR files as a parameter while starting JBOSS EAP server like -Daxis2.repo="D:\axis2\repository". Under repository I have modules folder which has rampart & addressing MAR files. After this configuration, I was able to engage rampart