3 Replies Latest reply on Dec 5, 2014 5:14 PM by Selvam Subbiah

    Following Simple BRMS Tutorial and Ran Into Problems (Updated)

    Kyle Smith Newbie

      Hi Everyone,

       

      I am following this tutorial: http://www.jboss.org//quickstarts/brms/helloworld-brms/index.html and ran into some problems. Everything appears to work up until running Maven from the 'Quickstart directory'. I have no idea what the 'Quickstart directory is. If someone could help me determine this that would be greatly appreciated. *I think I found the directory to run Maven from; please see the sentence below the first Maven error output*

       

      I tried running it from where Maven deploys it and tried running it from the directory that is created when downloading the tutorial and unzipping it on my desktop. None of these worked. I was thinking that maybe that the folder with the quickstarts would actually not be relevant since I did not actually use this folder when loading the repository for instance from Git but now I see that these steps are unrelated (loading repository from Git and using quickstarts folder to use Maven).

       

      So if someone could help me finish running this example BRMS application I would greatly appreciate it.

       

      When going to my Maven repository and going to what I think is the root of this project. I execute the specified Maven commands from the tutorial given in the hyperlink above and receive the following error:

       

      [INFO] Scanning for projects...

      [INFO] ---------------------------------------------------------------------

      [INFO] BUILD FAILURE

      [INFO] ---------------------------------------------------------------------

      [INFO] Total time: 0.086 s

      [INFO] Finished at: 2014-10-14T09:24:48-05:00

      [INFO] Final Memory: 4M/76M

      [INFO] ---------------------------------------------------------------------

      [WARNING] The requested profile "enable-test" could not be activated because

      does not exist.

      [WARNING] The requested profile "brms" could not be activated because it doe

      t exist.

      [ERROR] The goal you specified requires a project to execute but there is no

      in this directory (C:\Users\ksmith\.m2\repository\org\jboss\quickstarts). P

      e verify you invoked Maven from the correct directory. -> [Help 1]

      [ERROR]

      [ERROR] To see the full stack trace of the errors, re-run Maven with the -e

      ch.

      [ERROR] Re-run Maven using the -X switch to enable full debug logging.

      [ERROR]

      [ERROR] For more information about the errors and possible solutions, please

      d the following articles:

      [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MissingPro

      Exception


      Now I think I found where to run Maven from (Desktop\jboss-brms-quickstarts-3b51e1dd566af6cd843a99d919f81a8b976f2904\helloworld-brms). From this directory I receive different sorts of errors. Please read the error log below.


      [INFO] Scanning for projects...

      [ERROR] The build could not read 1 project -> [Help 1]

      [ERROR]  

      [ERROR]   The project org.jboss.quickstarts.brms:brms-helloworld-brms:6.0.2.GA-redhat-3 (C:\Users\ksmith\Desktop\jboss-brms-quickstarts-3b51e1dd566af6cd843a99d919f81a8b976f2904\helloworld-brms\pom.xml) has 4 errors

      [ERROR]     Non-resolvable import POM: Failure to find org.jboss.bom.brms:jboss-javaee-6.0-with-drools:pom:6.0.2.GA-redhat-3 in http://maven.repository.redhat.com/techpreview/all was cached in the local repository, resolution will not be reattempted until the update interval of jboss-ga-repository has elapsed or updates are forced @ line 65, column 25 -> [Help 2]

      [ERROR]     'dependencies.dependency.version' for org.kie:kie-api:jar is missing. @ line 75, column 21

      [ERROR]     'dependencies.dependency.version' for org.drools:drools-compiler:jar is missing. @ line 80, column 21

      [ERROR]     'dependencies.dependency.version' for ch.qos.logback:logback-classic:jar is missing. @ line 86, column 21

      [ERROR]

      [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.

      [ERROR] Re-run Maven using the -X switch to enable full debug logging.

      [ERROR]

      [ERROR] For more information about the errors and possible solutions, please read the following articles:

      [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/ProjectBuildingException

      [ERROR] [Help 2] http://cwiki.apache.org/confluence/display/MAVEN/UnresolvableModelException

       

      Does anyone out there know how I can fix these dependency issues?

       

      I fixed this issue myself this morning. I had to resolve the dependency issues in the pom.xml file to match what is actually in the maven repository!

       

      Respectfully,

       

      Kyle