2 Replies Latest reply on Oct 15, 2014 8:58 AM by Christian Weithøft

    Error when trying to deploy a quickstart using mvn jboss-as:deploy - Could not connect to remote://localhost:9999

    Christian Weithøft Newbie

      I'm new to JBOSS Wildfly and try to get some understanding of the product going through the Quickstarts.

       

      I run a Ubunto 14.10 box  with all updates.

       

      I have downloaded and installed Wildfly 8.1.0 Final and unpacked it to a local folder. Have defined a Admin user. Started the server in standalone mode. Can access both admin page (localhost:9990/console) and localhost:8080 to verify that the server is running)

       

      I also have installed maven (version 3.0.5) and have copied the settings.xml file from QUICKSTART_HOME to ~/m2/settings.xml.

       

      I run JBOSS development within Eclipse. I used Eclipse Marketplace to locate the latest JBOSS development (8.0.0 CR1)

       

      From JBOSS Central I fetched the jboss-helloworld quickstart, and have changed org.jboss.as.plugin ti "7.6.Final" in pom.xml. (is this correct?)

       

      I can use Eclipse to "Run on server" and get a nice "Hello world" page. Have tried to change the text a little to verify that I deploy a change.

       

      the problem is that when I try to use command line maven to deploy I get the error stated in the title. The full message is

      [ERROR] Failed to execute goal org.jboss.as.plugins:jboss-as-maven-plugin:7.6.Final:deploy (default-cli) on project jboss-helloworld: Could not execute goal deploy on /opt/projekter/java/jboss-helloworld/target/jboss-helloworld.war. Reason: I/O Error could not execute operation '{

      [ERROR] "operation" => "read-attribute",

      [ERROR] "address" => [],

      [ERROR] "name" => "launch-type"

      [ERROR] }': java.net.ConnectException: JBAS012144: Could not connect to remote://localhost:9999. The connection timed out

       

      What is wrong with my setup?

       

      Bonus info. When I deploy using Eclipse "Run on server" I can see a message in the Wildfly console that "jboss-helloworld.war" is deployed, so I assume that there is no access problems, writing .war files to standalone/deplaoyments.

       

      I hope someone can help!