2 Replies Latest reply on Nov 12, 2014 1:44 PM by Andrew May

    Problems connecting to JNDI remotely with WildFly 8.0.0

    Andrew May Newbie

      Hi,

      I'm having a strange problem connecting to JNDI from a separate JVM on the same (Windows 7) machine.

      I'm trying to retrieve the JMS Remote Connection Factory from JNDI and it always fails with this error (nothing shows up in the WildFly logs):

       

      SEVERE: Failed to connect to any server. Servers tried: [http-remoting://127.0.0.1:8080 (Operation failed with status WAITING after 5000 MILLISECONDS)]
      

       

      There is an existing application that runs within WildFly 8.0.0 (and has a customized configuration) that I was trying to connect to. It also has a client which makes remote EJB calls, and this is failing with the same error.

       

      To eliminate the possibility that it was this custom configuration causing the problem I downloaded a fresh distribution of WildFly and installed it. I also checked out the quickstart project and tried to run the "helloworld-jms" application (I changed the pom to use the 8.0.0 client BOM), but got the same error.

       

      I then repeated this last test (fresh WildFly and the quickstart) on a Linux VM and a different Windows machine and they both worked fine.

       

      Finally I opened the firewall on the first machine and made WildFly bind to 0.0.0.0 and I was able to run the helloworld-jms from the second windows PC talking to the WildFly instance on the windows PC I was having problems on - and it worked. I tried the reverse and it didn't work.

       

      i.e. It appears that the problem is with the client and not the server - but that's with 3 different clients on the same PC (helloworld-jms, my new JMS client and an existing remote EJB client) that all fail to connect.

       

      I reinstalled the JDK (needed to update anyway) and this had no effect. At this point I'm planning to install wireshark, but I have my doubts about what I will see.

       

      Any ideas about how I might be able to investigate what's going on here? I'm at a loss at the moment and this is my primary development machine that's not working (reinstalling everything would be a huge pain).

       

      Thanks,

      Andrew

        • 1. Re: Problems connecting to JNDI remotely with WildFly 8.0.0
          Andrew May Newbie

          I was able to capture traffic on the loopback interface using RawCap and I can see that there is a connection to port 8080 (GET /) that gets a HTTP 101 Switching Protocols response. There is a bunch of traffic after that but I can't tell what's going on. If anyone would find that useful I can upload it somewhere (doesn't look like I can attach it).

           

          So at least it is making some kind of a connection.

           

          I enabled TRACE logging in WildFly (just changed the main log level at the top of logging.properties), but it logs nothing while the client is trying to connect.

           

          -Andrew

          • 2. Re: Problems connecting to JNDI remotely with WildFly 8.0.0
            Andrew May Newbie

            Well, I found the problem. My company provided PC had Trend Micro installed that includes some kind of Proxy (TmProxy) running on port 6999 that gets a copy of all traffic. That was somehow interfering with the remoting (my network captures included this in addition to the calls to 8080) - it was more obvious once I had a capture from a machine that didn't have a problem.

             

            Disabled the services, rebooted and it works now.

             

            Hopefully my day and a half of pain will be of use to someone else in future!