2 Replies Latest reply on Dec 4, 2014 1:53 AM by Neetha Lokanath

    external deployment in jboss 6 EAP

    Neetha Lokanath Newbie

      hello,

      I have external deployment scanner something like this.

      <deployment-scanner name="external-deployment-scanner" path="D:\DFSRoots\DP2\Reports" scan-interval="0" auto-deploy-zipped="false" auto-deploy-exploded="false"/>

      Issue is, through my application, i am not able to download the file which are located under D:\DFSRoots\DP2\Reports .

      Is the deploymetn scanner configuration correct.

      Any idea what could be the issue

        • 1. Re: external deployment in jboss 6 EAP
          Jay SenSharma Master

          What do you exactly mean by

          i am not able to download the file which are located under D:\DFSRoots\DP2\Reports

           

           

          Also in your deployment-scaner configuration we see that  scan-interval="0"  which means hot deployments of the applications will not work, You will have to restart your JBoss in order to make JBoss scan the deployments (D:\DFSRoots\DP2\Reports) directory, This directory will be scanned only during server bootup.

           

          Also as you have set [auto-deploy-zipped="false" auto-deploy-exploded="false"]  which means now in order to tell JBoss to deploy applications you will have to also place a file with postfix as   "$APPNAME.dodeploy" in the deployments (D:\DFSRoots\DP2\Reports) directory, Because jboss will not auto deploy the applications until it is instructed by the marker files. You might notice following kind of messages in your log during JBoss bootup.

           

          JBAS015003: Found A.war in deployment directory. To trigger deployment create a file called A.war.dodeploy
          
          
          • 2. Re: external deployment in jboss 6 EAP
            Neetha Lokanath Newbie

            Thanks for the reply. It now worked when i set zipped and exploded to True. We have few static files in the war, which is available to download through web application for users. that download was not happening with this above settings. Now i made it to true, and worked!!

             

            Also, we have to disable hot-deployment here as per the client requirement so i have set it to 0.