2 Replies Latest reply on Dec 9, 2014 4:36 PM by Emily Jiang

    Java 8 support on Weld 2.2.x

    Emily Jiang Newbie

      Will Weld 2.2.x (CDI 1.2 impl) support Java 8? I took a look at the JavaVersions.java under the org.jboss.classfilewriter (Weld 2.2.5 release), which lists the Java version up to 1.7. Am I right to assume that the current supported java versions do not include Java 8? If yes, what is the plan for Java 8 support in the Weld 2.2.x repo?

       

      Thanks

      Emily