0 Replies Latest reply on Dec 10, 2014 1:30 AM by praveen Kumar

    Need to connect with protocol TLSv1.1 and above

    praveen Kumar Newbie

      Hi All,

       

      I am using Jboss remoting API for our RMI invocation with SSL protocol. I want to disable SSLv3 protocol onbehalf of recent POODLE issue in my application. So i am planning to use TLS v1.1 or higher in Jboss remoting. After i specify the SSL protocol as TLS v 1.1 i am not able to establish the connetion.

       

      Following is the code to configure SSL protocol:-

       

            InvokerLocator myLocator = null;

            Connector connector = null;

            myLocator = new InvokerLocator("ssl"+ "://" + "0.0.0.0" + ":" + "portnumber");

            connector = new Connector();

            connector.setInvokerLocator(myLocator.getLocatorURI());

             

            HashMap config = new HashMap();

            config.put(SSLSocketBuilder.REMOTING_KEY_STORE_TYPE, "JKS");

            config.put(SSLSocketBuilder.REMOTING_KEY_STORE_FILE_PATH, "my path");

            config.put(SSLSocketBuilder.REMOTING_KEY_STORE_PASSWORD, "password");

            config.put(SSLSocketBuilder.REMOTING_SSL_PROTOCOL, "TLSv1.1");

            SSLSocketBuilder builder = new SSLSocketBuilder(config);

            builder.setUseSSLServerSocketFactory(false);

            connector.setServerSocketFactory((SSLServerSocketFactory) builder.createSSLServerSocketFactory());

             

            connector.create();

            connector.addInvocationHandler("MYSYS", new MessageReceiverInvokeHandler(remoteObjectHandler));

              connector.start();

       

          The error i am getting is as below:-

       

      java.io.IOException: Error creating server socket factory SSL context: TLSv1.1 SSLContext not available

          at sun.security.jca.GetInstance.getInstance(GetInstance.java:142)

          at javax.net.ssl.SSLContext.getInstance(SSLContext.java:125)

          at org.jboss.remoting.security.SSLSocketBuilder.createServerSocketFactorySSLContext(SSLSocketBuilder.java:1197)

       

      I am not sure why its not accepting the TLS protocol. ?I am using the Jboss API v 2.5.0 SP2 and also i have tried with the latest version 2.5.4 SP5 and i am getting the same error.