2 Replies Latest reply on Dec 25, 2014 2:26 PM by Gayathiri Ruthraiyah

    Fuse JMX Navigator doesnt display the local processes in JBoss Developer Studio

    Gayathiri Ruthraiyah Newbie

      Hi,

       

      I am working on the following tutorial ], when i run the camel routes i am unable to find any local processes though i did refresh. When I run the routes I dont see any errors and below are the console logs.

       

      [INFO] Starting Camel ...

      [pache.camel.spring.Main.main()] MainSupport                    INFO  Apache Camel 2.12.0.redhat-610379 starting

      [pache.camel.spring.Main.main()] SpringCamelContext             INFO  Apache Camel 2.12.0.redhat-610379 (CamelContext: camel-1) is starting

      [pache.camel.spring.Main.main()] ManagedManagementStrategy      INFO  JMX is enabled

      [pache.camel.spring.Main.main()] DefaultTypeConverter           INFO  Loaded 176 type converters

      [pache.camel.spring.Main.main()] SpringCamelContext             INFO  AllowUseOriginalMessage is enabled. If access to the original message is not needed, then its recommended to turn this option off as it may improve performance.

      [pache.camel.spring.Main.main()] SpringCamelContext             INFO  StreamCaching is not in use. If using streams then its recommended to enable stream caching. See more details at http://camel.apache.org/stream-caching.html

      [pache.camel.spring.Main.main()] FileEndpoint                   INFO  Endpoint is configured with noop=true so forcing endpoint to be idempotent as well

      [pache.camel.spring.Main.main()] FileEndpoint                   INFO  Using default memory based idempotent repository with cache max size: 1000

      [pache.camel.spring.Main.main()] XPathBuilder                   INFO  Created default XPathFactory com.sun.org.apache.xpath.internal.jaxp.XPathFactoryImpl@6f65d2e6

      [pache.camel.spring.Main.main()] SpringCamelContext             INFO  Route: route1 started and consuming from: Endpoint[file://src/data?noop=true]

      [pache.camel.spring.Main.main()] SpringCamelContext             INFO  Total 1 routes, of which 1 is started.

      [pache.camel.spring.Main.main()] SpringCamelContext             INFO  Apache Camel 2.12.0.redhat-610379 (CamelContext: camel-1) started in 0.469 seconds

      [1) thread #0 - file://src/data] 1                              INFO  uk messages

      [1) thread #0 - file://src/data] 2                              INFO  other messages

       

       

      Could you please me to resolve the issue.

      https://access.redhat.com/documentation/en-US/Red_Hat_JBoss_Fuse/6.0/html/Using_the_Fuse_Developer_Tools/files/FIDEJMXEx…

       

      I tried to resolve the issue by looking into this link, but it didnt work - JBoss Fuse IDE 7.2.129 - JMX Navigator problem

       

      I tried in 2 different laptops but both didnt work. I have pointed the workspace to JRE7 and JMX Explorer is pointed to JDK 1.7 (C:\Program Files\Java\jdk1.7.0_71)

      IDE Version - JBoss Developer Studio 7.1.1.GA

      Windows 8.1

      JDK jdk1.7.0_71

      JRE 7

       

      Other laptop

      IDE Version - JBoss Developer Studio 7.1.1.GA

      Windows 7

      JDK jdk1.7.0_71

      JRE 6